Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
have a 2003 focus zx5 2.0 L
car runs great but once you turn on the a/c and come to a stop or slow down
it will shut down, did take the iac valve off and cleaned it,worked okay for a while.engine light came on....use my scanner and had a code PO 420
does this mean that i have a bad catalytic converter or a bad 02s
would this cause the above problems
 

·
Registered
Joined
·
666 Posts
the a/c shuts off or the car shuts off?
 

·
Premium Member
Joined
·
44,595 Posts
You have really answered your own question with the results you gave in the post...

Cleaning the IAC fixed it temporarily, then it "hung up" again and stopped working properly.

IMHO, I think I'd collect on a small bet that replacing the IAC would solve the problem longer than cleaning it did...

By all means, clean it again - check for free movement & reinstall, THEN see what happens. If the problem reoccurs AGAIN you have a definitive answer....

Luck!
 

·
Registered
Joined
·
1,543 Posts
I've been dealing with a similar issue on my brothers 01 ZX3 2.0. After changing the timing belt the car immediately had the notorious rev-hanging problem. I took off the IAC and cleaned it, and the problem was gone, but now apparently the car has a low idle and has died a couple times at idle. I bought a Hitachi IAC valve from partsgeek for about $50 and will be putting that on when I see the car again. I mention all this since the Hitachi one is significantly less expensive than the other brands, and it just arrived yesterday and looks like a quality part.
 
1 - 6 of 6 Posts
Top