Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter · #1 ·
Okay guys new problem hopefully last one for a month or so... while I drive there is wobbling in the front end. (new tie rod ends) so thats not the problem. I think it is the axle because when I brake it pulsates and pulls the steering wheel to the left. Also when i turn there is a lot of knocking like something is rotating and smacking the frame. I have not been under the car yet. I will tomorrow morning. I will add that when I brake I smell some kind of fluid, maybe oil, but I have not noticed any leaks under my car. I was just wondering if anyone can maybe point me where to look at considering there are many parts to the axle and what may need to be replaced. thanks guys
 

·
w/ my magic bag
Joined
·
29,472 Posts
I'd also look for a torn axle boot.
 

·
Registered
Joined
·
178 Posts
Discussion Starter · #5 ·
What exactly did you do to repair the "blown wheel cylinder" in your other thread?
Replaced wheel cylinder, shoes etc and replaced the line. And I have new rotors on the front. I did the front brakes a year ago.
 

·
Registered
Joined
·
178 Posts
Discussion Starter · #7 ·
okay guys got under the car. my swaybar end link broke and the grease fitting rubbed into the outer axle boot when I turned so it shaved the boot. looks like im replacing the axle boot and getting a new end link then hopefully problem solved. will update you guys when its done.
 
1 - 7 of 7 Posts
Top