Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
I'm having trouble with my automatic transmission. It started today to shift into neutral (?) during driving and lost power several times. Did anyone experience similar problems? I'd be thankful for any tip. - I am planning to bring it to the dealer on Monday - the car is six months old...

Thanks,

Chris
 

·
Registered
Joined
·
1 Posts
I monitor various webpages on behalf of Ford and I hope you don't mind me posting here. I just started monitoring this site so I apologize for my late response. Anyway, I hope your dealership has resolved your transmission issue. I looked around here and didn't see any bulletins related to your concern. If you're not satisfied with your dealership's resolution please contact the Ford Customer Relations Center. Visit http://www.ford.ca/app/fo/index.do for contact information in Canada.
 

·
Registered
Joined
·
2,091 Posts
Actually, Troyftw had this happen to him recently. I believe the dealer replaced the valve body in the transmission, but I am not sure if they replaced anything else. send Troyftw a pm and ask what else was replaced. Below is the link to his post.

http://www.focusfanatics.com/forum/showthread.php?t=176796
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #4 ·
I monitor various webpages on behalf of Ford and I hope you don't mind me posting here. I just started monitoring this site so I apologize for my late response. Anyway, I hope your dealership has resolved your transmission issue. I looked around here and didn't see any bulletins related to your concern. If you're not satisfied with your dealership's resolution please contact the Ford Customer Relations Center. Visit http://www.ford.ca/app/fo/index.do for contact information in Canada.
My dealer "Circuit Ford Lincoln" Montreal replaced the transmission valve body. The car was in the shop for 3 days. When I bought the car I knew that it was a new model and was expecting something to happen, absolutely no problem for me as long as I know it can be fixed. However, the dealer expected ME to pay for the rental car for the three days. Very disappointing.
 
1 - 4 of 4 Posts
Top