Focus Fanatics Forum banner

101 - 116 of 116 Posts

·
Registered
Joined
·
1,552 Posts
Ya if just going back and forth to work no. But I have a lead foot when it comes to the twisties and this setup with coilovers is like being on train tracks.
 

·
Registered
Joined
·
24 Posts
I'm not sure how to really tell other then getting them swapped out. I saw a TSB for the Focus that talked about the control arms as being one of the possible culprits. It was for me, and I didn't know until I changed them. I also have done my shocks and struts, but the noise you are talking about in my case was the control arms.
 

·
Registered
Joined
·
53 Posts
I bought a 2009 FF coupe SES in Feb.2009 I only have 12,000 miles but for a while now It feels like the front wheels are going to fall off.

I haven't been on here since the purchase but came to look around and I'm glad I did. My car definitely has this symptom...Thanks

What's the warranty 36,000 or five years on this ??
 

·
Registered
Joined
·
203 Posts
I had that issue with my 09 coupe and the problem was a cracked front control arm.
 

·
Registered
Joined
·
20 Posts
here's the sound I have, cant figure out if its the sway bar links or control arm, whatcha think? its the clacking sound. https://www.youtube.com/watch?v=53AEGEaY5kw
I'm also at 105k and am the 3rd owner, so i have no idea if they've been replaced before. but they look in fairly decent condition besides the rear ones being bent, (sway bar links)
 

·
Registered
Joined
·
2 Posts
I have a 2011 ford focus 1.8 tdci with 32k miles on it. When a I go over sharp bumps with the steering wheel turned right I get a metallic click noise from under the hood on the front left side. I dont know if its a sway bar or strut upper mount problem or if there is anything wrong with the steering wheel system. I would appreciate any help
 

·
w/ my magic bag
Joined
·
29,321 Posts
I have a 2011 ford focus 1.8 tdci with 32k miles on it. When a I go over sharp bumps with the steering wheel turned right I get a metallic click noise from under the hood on the front left side. I dont know if its a sway bar or strut upper mount problem or if there is anything wrong with the steering wheel system. I would appreciate any help
More likey the end links.
 

·
Registered
Joined
·
2 Posts
Only the left side with the steering wheel turned right gives the noise. Just passed the inspection and nobody is able to detect the problem because its a slight noise.
You mean the end links of the sway bar?
thanks for answering
 

·
w/ my magic bag
Joined
·
29,321 Posts
Only the left side with the steering wheel turned right gives the noise. Just passed the inspection and nobody is able to detect the problem because its a slight noise.
You mean the end links of the sway bar?
thanks for answering
Correct= front sway bar end links.
 

·
Registered
Joined
·
11 Posts
My sway bar end links seem to last about 60,000 miles. When 1st trying to diagnose the problem I removed each wheel and yanked on the sway bars to see if they were loose but to my surprise they were tight. The problem is that when the suspension is in the air is puts a fair amount of downward pressure on the sway bar making them tight and hard to diagnose. When I removed the sway bar it was obvious both joints were trashed.

Moral of the story. If you haven't changed your sway bars in 60K miles and hear/feel front end noises then change the sway bars.
 
101 - 116 of 116 Posts
Top