Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Im in the process of swapping out head units in my 2005 Ford Focus ZX3. Yesterday after I pulled the head unit and was installing the speakers I noticed the light was flashing. I tried pulling the battery cable to reset it, no go. Im going to stick the original head unit back in this morning to see if that will kick it off.

Has anyone run into this before when swapping head units?

Update: Radio apparently has nothing to do with this issue. I just tried putting the unit back in and no luck.

Anyone know a resolution to getting this blinking light to turn off?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #2
Update, I put the radio in and finished putting the dash board back together and the light went off.


Now the light is back to blinking, this is crazy!!!

Anyone have any ideas on this or seen this before?
 

·
Premium Member
Joined
·
44,595 Posts
Light does a constant blink while car is turned off, only time to worry is if it flashes fast when trying to start instead of turning off then.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
In reading other posts it looks like other folks also see this light blinking. If this is normal and shouldn't be an issue that's fine yet I have to ask:

I know this light has not blinked before, why did it start now? Was something not working right before?
 

·
Premium Member
Joined
·
44,595 Posts
It's normally a slow blink, and often not noticed.
 
1 - 5 of 5 Posts
Top