Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Picked up my new Focus Titanium end of June in Canada... Love this car so much... I took it in for mudflaps, and undercoating. The only issue with it is the ambient lighting came on randomly, dials did not work to control it. Now, it has been in for a week. It's not the dials, electronic people have emailed corporate level, and were told they have to trace the wires to look for a short somewhere. Will pick it up again tomorrow, and take it back again next week when they have more electronic staff... Oh well, I just want it to work. Ford will supply me with a rental car. They have been awesome so far.
 

·
Registered
Joined
·
1,878 Posts
Nice that they supplied you with a rental. Who provided the rental? Ford or the dealership? Regardless, kudos to them for taking care of you. Good to see someone at some level is interested in selling a product and supporting it when you had a problem.
 

·
Registered
Joined
·
444 Posts
My ford dealer was really good with me when i had to bring my car in for repair. I was rear ended 1 week after owning the car, while they where replacing the back bumper the body shop manager gave me his own brand new 2011 f150 to use for the day/night.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4 (Edited)
2012 Focus is still back at the dealership, trying to get the ambient lighting working. Last phone call I had from them today informed me that they are stumped as to why it's not working properly, and have emails in to the corporate level!! Miss my little car.... Have to keep driving the rental they left me with!!

Ambient lighting is now fixed... problem with the power board to the light.... Switched with another vehicle , and now have my fully functioning Focus!!
 
1 - 4 of 4 Posts
Top