Focus Fanatics Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
Recently got back into; small dent in trunk, things went downhill from there. Car died the day of accident and I was getting a lean code. Drove it for a while with the lean code and found out there was a piece of fuzz on MAF. Cleaned that and check engine light went away. Car acted right for about a week and then seemed to act sluggish driving down the highway. It acts like there is a lack of power, no check engine light, but I sure think something isn't right. I can set the cruise for 75 and even the slightest incline and the car will lose speed, drop down out of overdrive and shoot the RPM's up to 4000 to get it back up to 75. Where normally it wouldn't need to shift down to maintain speed.

Had it in at the dealership this morning and they can't find anything wrong with it. Am I just imagining the problem or what?
 

·
Meh.
Joined
·
10,609 Posts
I'm just gonna throw this out there but were you using the AC. That will make you car feel underpowered. The only other thing that I would know of is a plugged fuel filter but that would have a bogged down feel unlike what you described.
 

·
Registered
Joined
·
2,193 Posts
Only thing I can think of , if it has to do with being backed into. Is the fuel tank vent. If it is pinched , the fuel pump will start to have a hard time pumping if the tank has negative pressure. ? It will start to slow down or lose power. Other than that. It must may be a coincidence , when was the last tune up. Plugs , fuel filter and such ? Is the cel back on ? If so post Il the codes.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #4
Ya I agree with the AC being on, but it acts the same with or without the AC on.

When things started getting bad, I first replaced all fuel on the assumption I could have gotten 24% ethanol, and I also replaced fuel filter with that round of replacements.

We only have a small dent in the trunk, I'm not exactly sure where the fuel tank vent is to check to see if its pinched. I did also replace the plugs with some NGK ones and gapped them to 0.051. If i'm off on the gapping, could that make a difference(I just did it with the $0.75 tool from oreillys).

Also no check engine light since I fixed the MAF issue, and i have a laptop OBD2 program and it doesn't have any "pending" codes that are showing up. With the OBD2 software(ProScan) I don't know what to notice if things are not what they should be either so if anyone could chime in on what I could look for in the software.
 

·
Registered
Joined
·
2,193 Posts
I personally like NGK plugs , for my bike and Jet ski. I have seen some threads on here where guys were having issues with them. Try going back to the originals.
 

·
Registered
Joined
·
116 Posts
you could use the program if it has a view data option to check your fuel pressure that will tell if the vent is pinched off.
 

·
Hatch Nation #136
Joined
·
2,043 Posts
When was the last time you changed your transmission oil? The issue might be totally unrealted. Like, if you had a previous issue with the MAF and it was running like crap, you may not have noticed the shifting issues until you got everything fixed and then it started to show itself.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #9
Its got 104,000 miles on it, and my wife bought it at 80,000 and we have never changed trans fluid. Whether or not it was changed before she bought it, I don't know. It was running perfect 3 in June before we got backed into.
 

·
Hatch Nation #136
Joined
·
2,043 Posts
Take a look at the tranny fluid, then. It should be bright red. If it isn't change it. Even if it doesn't fix the problem, the trans oil on these cars should be changed every 30k.
 

·
Registered
Joined
·
116 Posts
^^ agreed i dont know exactly what it should read ill see if i can remember to check after i re-install my alt.
 
1 - 11 of 11 Posts
Top