Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter · #1 ·
hello all. pretty sure the voltage regulator in my alt is about to die so im just gonna replace the whole damn thing. i realize that ford and all its wisdom and glory decided to mount it on the bottom of the engine[duh] anywho what is the best way to get at it, i would really like to avoid moving the engine around if at all possible
 

·
Hatch Nation #136
Joined
·
2,043 Posts
You're going to have to move the engine around. There isn't really any way around it. Luckily, if you have stock motor mounts, there is a ton of play. Just make sure you put a piece of wood between the oil pand and jack and you'll be good.
 

·
Registered
Joined
·
1,093 Posts
You may want to monitor your charging system voltage before replacing the alternator - unless of course you have 150k miles on the original alternator and you have check for wiring problems.

Some parts stores/retailers, with competent staff, have the means to test your system (their interpretation may be another story).

Or - you could enter the instrument cluster test mode and monitor the battery voltage yourself - from initial cold start up to, high rpm warmed up conditions. And verify this with a meter right at your battery.
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #4 ·
well here is my issue everyonce abd a while the battery light will come on the engine will stumble abd then all will be fine. but it has become more frequent and the bat light stays on for a lil longer. this happens at random times having no correlations with starts and what not
 

·
Registered
Joined
·
784 Posts
All you really need to remove is the passenger side motor mount in front of the timing cover. Takes a few minutes to remove and that should give you all the movement you need. I replaced my alternator a few months ago, it came out from the top pretty easily with the motor mount removed. I don't see any other easy way to get it out. I looked from underneath and I couldn't see any place it would easily fit through.
 

·
Registered
Joined
·
17 Posts
Are you working an a Zetec or the DOHC Duratec?

My battery light just came on, and using a voltmeter, the alternator is not charging. Mine is an 04 ZTW wagon with the 2.3 DOHC Duratec, and the alternator looks like a total PITA to remove! It's mounted right in the back by the exhaust manifold, and I don't see any possible way of it coming out the top. Any tips on removing and installing a Duratec alternator?

Thanks!
 

·
Hatch Nation #136
Joined
·
2,043 Posts
Are you working an a Zetec or the DOHC Duratec?

My battery light just came on, and using a voltmeter, the alternator is not charging. Mine is an 04 ZTW wagon with the 2.3 DOHC Duratec, and the alternator looks like a total PITA to remove! It's mounted right in the back by the exhaust manifold, and I don't see any possible way of it coming out the top. Any tips on removing and installing a Duratec alternator?

Thanks!
He's running a Zetec. It is the SVT.
 
1 - 7 of 7 Posts
Top