Focus Fanatics Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1,474 Posts
Discussion Starter #1
Well, my alternator is taking a crap at 37K miles(!]

I was looking at a 145 Amp replacement from PA Performance. They only list them for the Zetec DOHC, and say nothing about the SVT. Does anyone know about the fitment, and if they are the same. I am going to go bigger with my stereo system, and want to get something that is gonna hold up under heavy load. Any input would be greatly appreciated.[:
 

·
The Librarian
Joined
·
13,116 Posts

·
Registered
Joined
·
168 Posts
Will the 6G fit on the duratec engines? I still am unable to find an alternator that fits an 05 ZX3 (any of the parts sites list it as maybe something like Focus 00-06, but then in the description it states it is for the Zetec)
 

·
Registered
Joined
·
563 Posts
That won't fix the problem. That is merely a band aid on a stab wound. If your charging system can't keep up with the amperage you are pulling, only an alternator will fix it. Caps aren't the miracle cure some people are made out to be. They are an extra strain on an already weak charging system.
 

·
Registered
Joined
·
1,734 Posts
Scott,

Did ya put the stock pulleys back on and check the voltage? I'm curious if it did anything and if I should be worried.
 

·
Registered
Joined
·
1,474 Posts
Discussion Starter #9
I put my stock pullies on and my alt puked completely. I will se what happens when I get my car back at the end of next week. Something let loose in the valvetrain too, and they have lots of work to do.

BTW Tim, your voltage is on the low side, it should be at least 14.4 volts, and yours was at 13.7 volts with no load.
 

·
Registered
Joined
·
121 Posts
DetroitBass said:
That won't fix the problem. That is merely a band aid on a stab wound. If your charging system can't keep up with the amperage you are pulling, only an alternator will fix it. Caps aren't the miracle cure some people are made out to be. They are an extra strain on an already weak charging system.
oh, now I know, I will keep that in mind, thank you oh wise one for teaching me the ways of the grasshopper, lol
 

·
Registered
Joined
·
1,145 Posts
I have a 04 D23E and i was wondering if anyone has noise problems with their altenator? It's not taking a crap im sure, but it makes a kind of high pitched sound, not a squeek or squeel like the pulley bearing, but an electrical wierd sound....
 
1 - 12 of 12 Posts
Top