Focus Fanatics Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter #1
anyone else have chronic problems with alternators? ive replaced my alternator like 4 times. just keep warranty'in it. i think the diode bridge keeps failing. my battery cable is fine and has been replaced. can anyone give me some insight on what this might be? car is a 04 zx3 zetec
 

·
Registered
Joined
·
25,627 Posts
^^^ Do you have an aftermarket sound system??? Betcha do. Its just a marginal alt. for a stock car. If you have a sound system you need to shell out for a big battery (optima or something), and a bigger badder alt. ( stinger , etc.)
 

·
Registered
Joined
·
755 Posts
I have a couple amps, nothing too huge like 500 watts total and I have only had to replace my battery twice, put an interstate in it and I have never had a problem since, ohh yeah and maybe upgrading the ground wires might help, or upgrade the power wire from the alt to battery, maybe it's working too hard and running the alternator all the time and killing it, or computer problem...
 

·
Registered
Joined
·
182 Posts
Discussion Starter #6
do not have a sound system. I can't figure it out
 

·
Registered
Joined
·
9 Posts
get a bigger altenator if you have a system, costs a little more, but worth it.

didnt even need to bay a new battery for the system, still have the wal-mart one in their
 

·
Registered
2017 Focus 1.0 Ecoboost 2003 Focus ZTW
Joined
·
270 Posts
I've replaced mine twice now. The original one went out around 70k miles. The first replacement lasted about 10k miles. The second one is at about 40k miles and still going. They warrantied it no problem but what a bitch to replace. The only electrical things I've added is a daytime running light/auto headlight kit from Ford and a sat radio receiver but I can't see that stuff causing too much load.
 
1 - 9 of 9 Posts
Top