Focus Fanatics Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
770 Posts
Discussion Starter · #1 ·
I starting hearing this..whirring kinda sound almost like I had a SC. And now when I come to a stop my idle drops down to about 500rpm for a second or 2 and the oil light flickers on and off really quickly for those couple of seconds. Engine performance hasn't changed but the sound and that light worry me. Suggestions?
 

·
Registered
Joined
·
770 Posts
Discussion Starter · #2 ·
And now the car died. Super I'm on the side of the fwy as I type this. Heard some scratching noise while driving then when I was exiting it just died. It cranks very slowly, like a sobbing little kid. Battery? The scratching noise makes me think alternator? Update once I stop hating my life.
 

·
BACON?
Joined
·
3,170 Posts
Have you checked to make sure you put oil in it? just asking the stupid question that needs to be asked.
 

·
Registered
Joined
·
770 Posts
Discussion Starter · #4 ·
Haha yes oil is at the MAX line checked it Again this morning before I left for what I thought was gonna be another day of work.
 

·
Registered
Joined
·
770 Posts
Discussion Starter · #5 ·
So I've read a few dozen posts on various forums (dodge, evo, bimmer) and the answer seems to be to replace the oil pressure sensor?
 

·
Registered
Joined
·
202 Posts
I thought my OP switch was going so i switched it out but i dropped the pan at the same time to redo the gasket and poke around....my oil pick up tube was disconnected laying in the pan. Cant for the life of me figure out how 3 bolts backed themselves out. Caused some wear on my engine lots of metal glitter. It still read full on the dipstick it just would pick up the oil to lube anything. The scratching and slow crank makes me think your pistons arent oiled
 

·
DTC P0606
Joined
·
3,364 Posts
Oil pressure sensors don't fail that frequently; they're too simple (pressure activated contact switch.) Taken together with your other symptoms, I'd say it's trying to tell you something...
 

·
Registered
Joined
·
770 Posts
Discussion Starter · #9 ·
Tell me what?! This car is so full of problems im finding it hard not to get rid of it.
 

·
Registered
Joined
·
73 Posts
So another stupid question...... How many quarts of oil did you put back in after your oil change, should have been right around 4.5
 

·
Registered
Joined
·
770 Posts
Discussion Starter · #12 ·
And btw I put in a new battery bc the one in there was bad. I still get the oil light flicker @ idle and that whirring sound.
 

·
Registered
Joined
·
7,530 Posts
You have the BSD and the oil light is flickering. My bet is on the plug to the main feed for the balance shafts not being installed tightly (or has backed off a bit) and is allowing oil pressure to bleed off, basically starving components downstream of it of oil.

If you are hearing a scratching noise and the oil pressure light keeps flickering I would seriously re-consider driving the car till its fixed and I would be pulling the oil pan off to inspect inside pronto.
 

·
Registered
Joined
·
770 Posts
Discussion Starter · #15 ·
I heard the scratching only one time but I see the reason why I should be taking the precaution thanks Jet.
Also another question, so I need to reprogram my tune to the car since I had te battery pulled/replaced?
 

·
DTC P0606
Joined
·
3,364 Posts
No. Disconnecting the battery will not affect or erase any tune you already have "loaded" on the PCM. You'd need to remove the tune with the flasher again through the OBD port to uninstall it.
 
1 - 16 of 16 Posts
Top