Focus Fanatics Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter #1
After searching both sites I didn't find anyone with my specific problem. I have a 02 sedan. The ac has a low pitched squeal when on levels 2 or 3 but not 1 or 4. It sometimes goes away when moving but comes back when stopped with the brakes on. It does it when on ac or full ac with the circulation selected too. It sounds like it's coming from inside so I don't think it's the compressor or belt. Any thoughts?
 

·
Registered
Joined
·
114 Posts
Discussion Starter #3
Perfect! Thank you. Not sure why that didn't come up in my search
 

·
Registered
Joined
·
2,484 Posts
I had blower motor squeaking, there were leaves in the fan. Added a cabin air filter to prevent that from happening again.
 

·
Registered
2004 Focus Wagon, Zetec DOHC, Auto
Joined
·
1,590 Posts
I had blower motor squeaking, there were leaves in the fan. Added a cabin air filter to prevent that from happening again.
That was my issue too. I oiled the motor and cleaned all the leaves from the fan and also from the back of the evaporator coil...everything smelled and worked better after that.

I didn't put in a cabin filter because I knew the plastic clips on the cowling would not stand up to the filter being replaced on a regular basis. So, I cut out a piece of window screen I had and fit that onto the placeholder in the filter slot. Been fine since.......
 

·
w/ my magic bag
Joined
·
29,468 Posts
All of the above^^^^^^^^
 

·
Registered
Joined
·
114 Posts
Discussion Starter #7
Thanks for the info everyone. A cabin filter was on my list to check. Ill make sure to clean everything out well when I oil the fan
 

·
Registered
Joined
·
4,410 Posts
Bought a filter from rockauto; they and amazon had it listed as "fits my car". Opened the cowling and filter was too small. Any chance someone knows a filter part number that will properly fit?

Yeah Felix, my cowling clips had been butchered by PO. Funny, I never noticed until the day I went to open it up. Repaired/replaced them using misc hardware.
 

·
Registered
2004 Focus Wagon, Zetec DOHC, Auto
Joined
·
1,590 Posts
Sorry Marde...I don't know the filter P/N. When I look mine up I get several different filters shown as being the correct fit, so I dunno.

For unplugging the evaporator drain tube, I have used this process: http://www.focusfanatics.com/forum/showpost.php?p=4860302&postcount=16

When my blower started squeaking I took this cleanup a step further. I went in through the blower housing and did a major cleanup on the mulch pile of leaves behind the evaporator. I used the same wet/dry vac with the heater hose attached. After removing the blower and resistor block, I used a mirror and flashlight so that I could see the mulch pile. By snaking the heater hose in there I was able to suck it out. What a difference it made!!!!!
 
1 - 9 of 9 Posts
Top