Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
ok so i just put a new stage 1 clutch, lightwieght flywheel, throw out bearing, new tires, air filter, and rear o2 censor, on my car within 1500 miles ago

1)but for some reason now im gettin about 20 to 22 mpg when i use to get around 30-34 mpg, (before you go and delete or watever this thread cause someone else talked about mpg READ THE REST!) -- I always service my car usually before its needed, there are no "cheap" parts on it and pretty much everyhting is new

2) next problem is that when i let the clutch out at a stop the throw out bearing rattles continously 99% of the time, sometimes it doesnt but then you push the clutch in and let it back out and it starts again, iknow the flywheels is suppose to make a little noise but this is noticably audible

3) finally, recently like in the past 2 weeks it feels like something holding my car back, before if you got on the gas you were goneeee, but now it just slooooooooooooowly gains rpm and speed it feels kinda like im trying to pull something down the road behind me

i have no idea why its doin this can anyone help?

thanks
 

·
Registered
Joined
·
26 Posts
Discussion Starter #2
OH also my AC blows all the time when the cars on even if its on 0 its not alot but its noticeable is that normal?
 

·
Registered
Joined
·
3,737 Posts
> y AC blows all the time when the cars on even if its on 0 its not alot but its noticeable is that normal?


It is normal to get a small air flow through the system while you are moving, increasing as speed increases. It is not normal to have noticeable air movement out of the vents when the vehicle is stopped and the fan switch is on 0.
 

·
FUBARCUS
2003 ZX3 2016 FoST
Joined
·
7,790 Posts
Lightweight flywheels tend to make lots of noise that is normal. there is air that will flow through your vents that are turned off just so you get fresh air so you dont die from lack of oxygen. It should not be noticeable at low speeds or stops but at higher speeds it could be mildly noticeable. for the bogging you could clean your maf sensor and make sure your airfilter is clean. Maybe a clogged cat I'm not really sure on the bogging.
 
1 - 4 of 4 Posts
Top