Focus Fanatics Forum banner

21 - 28 of 28 Posts

·
Registered
Joined
·
1,154 Posts
Discussion Starter #23
What cams are you running? Any chance you could have swapped the intake and exhaust cams?
Crower stg 1. I don't think it's possible to get the two mixed up since the intake cam has the cam position sensor tab. I'm pretty sure a sensor somewhere failed because it was running moderately fine prior to all this. It's just tracking down the sensor sucks since there is no CEL for some reason.
 

·
Registered
Joined
·
7 Posts
Hey guys since this is one of the very few active chats.... I have an 06 ZX4 the quick connect clip broke that connects to the back of the fuel filter or front the pressurized side, finally got it together the runner grommet piece inside went bad and removed it spitting fuel still does anybody know the part for this part
look up the diagram for the fuel filter online to see if you can find the part on the diagram & part number
 

·
Registered
Joined
·
50 Posts
So I found out thru Ford that it’s an obsolete part..... but I managed to find a new clip and then I had to sand the plastic grommet down about 2mm and I was able to get it to lock into place luckily enough
 

·
Registered
Joined
·
7 Posts
well am glad you could solve your problem. Ford has a lot of the diagrams for most of there cars , the problem is finding them
 

·
Registered
Joined
·
50 Posts
Yeah I spent about an hour on the phone with them emailing back and forth diagrams to find out that someone had actually made the line already so I was looking for a custom part apparently. I’m finally digging into the car and finding parts that I want which is way harder than I thought but they don’t make much for my year. I have seriously thought about financing a newer RS
 
21 - 28 of 28 Posts
Top