Focus Fanatics Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1,091 Posts
Discussion Starter #1 (Edited)
Yet another rant, so please don't take this the wrong way.

Please see http://www.focusfanatics.com/forum/showthread.php?s=&threadid=89486&highlight=p0442 for the precursor.

Guess what? After changing the part, the FREAKIN' engine light came back on! WTF? Ok, so I was pissed. I took it back to Ford, and they put it back on the test set.

Remember, my 2nd to last quote in my last rant was, "Those bastards....now let's just hope that they troubleshot the problem right and that I don't have to change out any more parts."

Well, guess what? They ordered the wrong Rakafraka part...those sumamabitches! So, this time (crossing my fingers), I'm hoping they ordered the right part. I think they did cuz after I changed the...2nd hose and inspected the removed part, I could see a 1/4 in. hole in the hose. I noticed in the new part, it was the same length and size, but near the one connector I noticed that they had re-engineered it slightly by adding a 4 in. peice of hose over the original, so I know they've had problems with it before which just ticks me off just that much more. Wow, that was a really long sentence.

Anyway, changed it no problem, but you know it's bad when Ford secures one end with black duct tape. WTF? I'm thinkin' it had to be original equipment cuz it basically fell apart in my hand. Sounds like a McGuiver moment to me. I dunno.

Anyway, I hope it is fixed now (the evap system), but I'm still having a weird idle problem. It tends to hang at 1500-2500 rpms...if it's not one thing it's another.

Again, thanks for reading.

*Edit* The Dillhole that's "been doing this for 29 years" at Ford said my rev limiter should be set at 3-4k. WTF? I started up the car to show him and revved it and he said, "He wasn't going to argue about it." I almost test drove a new Focus just to piss him off and to reveal the results. Stupid Ass hair. Never heard of such blasphemy for a 5 speed.
 
1 - 1 of 1 Posts
Top