Focus Fanatics Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Okay so I've been dealing with the tricky and annoying 4.2" screen to the 8" Sync 3.

So far everything is working, well almost. Purchased the 8" Sync3 APIM, ACM and Sony faceplate from eBay.

I have it currently installed with the Sync3 APIM, original ACM (CD player) and the Sony faceplate and everything is working except for phonecall audio and sync voice alerts. The microphone is working as I can make calls and I can be heard on the other phone, but I do not get audio in the car. Same goes for sync voice commands. The car hears be and can respond to what I say but I don't get any audio. Bluetooth music does work however from the same phone as I attempt to make a call from. The steering wheel controls work for radio volume as well. So far the best setup as everything works except for phone calls and sync.

If I install the ACM from the Sony system I get the bluetooth audio and sync voice, however I can't seem to get the faceplate volume controls to work. All the other buttons do work on the Sony faceplate as I have wired it in but no volume control and the steering wheel buttons do not work for volume either. Would work except its too loud or too quiet.

I've managed to do this without cutting any wires so can go back to the 4.2" myford radio if I need to, but would like to get the bluetooth audio working. CarPlay and Android Auto is working too after I upgraded the software so this issue is the only thing left to figure out. Part of me thinks it could be the ACM programming as swapping between the two ACM units without changing the wiring gives me the two different outcomes.

I've been studying over the wiring manual for the focus and can't figure out what I am missing. If anybody has any ideas let me know.
 

·
Registered
Joined
·
2 Posts
Did you figure this out? I have an F150, did pretty much the same thing, 4.2" no Sirius to 4.2" with Sirius, and I have the same problem with the voice command and blue tooth

Thanks,
 

·
Registered
Joined
·
2 Posts
I just got a hold of a another guy. The ACM need to be programmed to work in your vehicle, thats why the voice commands dont work
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
I just got a hold of a another guy. The ACM need to be programmed to work in your vehicle, thats why the voice commands dont work


Yeah, basically the conclusion that I have come to. Haven't gotten around to trying to program anything as of yet.

Have everything working except voice commands, and voice for phone calls. Adequate for the moment so either going to try manually via focccus or may see if a dealership could help as well.

Believe the APIM needs to be set to 6 speakers and the ACM set for touch screen in my case.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
Maybe I'm not remembering correctly but I think you can set your radio type to MFT using foCCCus.
Yes the settings are available in foCCCus as I have downloaded and viewed all the settings. I only mildly trust myself to reprogram the car, and am taking my time on this step.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #9
So, I've updated via focccus the settings and currently still no phone audio. Adjusted 172 with the original ACM. Nothing has changed as of yet.

Will swap out the ACM at some point to the one that came with the 8" Sync 3 radio and see what focccus pulls for info and settings and will try again.

APIM is showing an error of not communicating with the digital audio processor which clearly is not present so not sure if that is leading to other issues.

Will advise of how it goes.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
124 Posts
Hello
I'm interested IN performing this to my car.
Would you please give me more info about it? Maybe some pictures of what you got and the electrical connections you did? Also, did you do a plug n play installation or did you have to cut sone wires?

Regarding you issue, look for any dtc codes to see if this give you a clue

Thanks
 

·
Registered
Joined
·
124 Posts
So, I've updated via focccus the settings and currently still no phone audio. Adjusted 172 with the original ACM. Nothing has changed as of yet.

Will swap out the ACM at some point to the one that came with the 8" Sync 3 radio and see what focccus pulls for info and settings and will try again.

APIM is showing an error of not communicating with the digital audio processor which clearly is not present so not sure if that is leading to other issues.

Will advise of how it goes.


Sent from my iPhone using FF Mobile
Hi
Did you have any luck after changing as-built data on focccus?
I'm almost done with my harness production and I will be soon installing everything.
 

·
Registered
Joined
·
43 Posts
I'm going to assume that you have it considering that you have audio period, but do you have the Sony amplifier installed in the trunk? With the mft system, all the sync and phone call stuff is run through that amplifier.
 

·
Registered
Joined
·
124 Posts
hello
i just finished my wiring in order to install a sync2 apim on my 2015 Focus SE.
I would like to share with you my state of the job and see if you could help me out with some issues im having:

-Steering wheel buttons dont work. I kept the original wiring on this one. There are 2 wires that used to go to the old 4" screen. I re-routed them to pins 46 and 47 on new APIM

-DSP is missing. I havent been able to find the correct bytes in order to program the APIM and tell it not to look for the DSP. This is causing me the following issues:
*Speed compensated volume is always OFF. Cant turn on
*Cellphone calls dont go through the speakers
*Cant change bass/treble settings

-Parking lines (Active Guidelines) dont show when camera video is on

-Car drawing with parking sensors wont show on the screen when in reverse



Regards
 

·
Registered
Joined
·
19 Posts
Discussion Starter #14
I'm going to assume that you have it considering that you have audio period, but do you have the Sony amplifier installed in the trunk? With the mft system, all the sync and phone call stuff is run through that amplifier.


No DSP module in the trunk. Just need to turn it off so it doesn’t look for it. With out it things actually work except for the speed adjust volume and visually it screws up the bass/treble/balance and fade settings. But the setting work when adjusted on the screen.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
19 Posts
Discussion Starter #15
Long lost update. Too a moment to program the ACM and APIM in FORScan and everything is working. Have phone audio, and APIM has bee set to turn off looking for the DSP.

Only thing not working is the compass on the non-nav sync 3 but there is nothing plugged into the antenna plug so that’s an obvious one. Just need to split the sat radio antenna or use it and turn off sat radio to fix that.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Hi,

I have a 2013 ford focus st in England, U.K.

I have the 4.2" non nav sony head unit at the moment. I want to upgrade to a 8" sat nav system. Please can you help me. DAB/Bluetooth etc but no sat nav.

I have a usb and aux in the media hub.

Can i purchase a 8" MFT system and simply plug it in and swap the media hub for one with a sd slot.

Will i need to make changes to the wiring to retain the functionality?

I would really really appreciate your help.

Thank you
Sam
 
1 - 16 of 16 Posts
Top