Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Driving along, no pre-warning. Go to shift, let the clutch out and no go. It's like the clutch is still engaged. I can shift into all of the gears fine. I drive the car fairly conservatively. The clutch was not slipping beforehand. The car only has 37k miles. I did a search but didn't see anything related. Any ideas? Thanks in advance.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Just heard back from the dealer. The slave cylinder leaked. Less than 37k miles and 3.5 years old and Ford won't cover it under warranty. It's considered a wear item. I don't beat the crap out of the car and the clutch discs are still like new and I'm pissed it won't be covered. What a shame.
 

·
Registered
Joined
·
980 Posts
Just heard back from the dealer. The slave cylinder leaked. Less than 37k miles and 3.5 years old and Ford won't cover it under warranty. It's considered a wear item. I don't beat the crap out of the car and the clutch discs are still like new and I'm pissed it won't be covered. What a shame.
I call BS on the dealer/Ford. The clutch slave cylinder is a powertrain item - not a wear item (like brake shoes, etc - by that thinking the entire vehicle is a 'wear item'). Powertrain should be covered 5 years / 60K miles. Call Ford Customer relations. Or get it it fixed at a reputable independent shop, save your reciepts, etc, and then take the dealer to small claims court and get your money back. Im not a lawyer so get other opins.

>> https://www.carchex.com/content/ford-warranty <<

Good luck
Paul
 
1 - 4 of 4 Posts
Top