Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Fellas, I am very desperate right now. I've been searching for days and can't find what I'm looking for. To make a long story short, I'm driving a 2014 ford focus. Someone who is an ex-friend ripped out the cable for the maf sensor connector out of pure spite. The cables are still there but the connector was detached. I found it a day later and trying to put it back together myself but I do not know what order the cables are supposed to be connected in. The colors are

light blue w a green stripe
white w a black stripe
yellow w a light blue stripe
green w a brown stripe.

its only 4 connections.

I got into a very bad car accident a month ago and this is a rental I'm driving. I cannot possibly afford financially to bring this back in this condition. Anyone who can help with a diagram or something, I would be eternally grateful. Thank you in advance.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thank you greatly for the response Foci3. :)

the only question I would have on that is that the connector as shown on the diagram is 1-6. But the connector that I'm holding in my hand is number 6-1 when I'm holding it at the same angle or direction as the drawing. Should I just follow the numbers on the chart and connect them 6-1 or should I follow the order that's shown in the diagram and plug them in 1-6?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
wait, I just realized. I'm holding the piece backwards. My absolute stupidity. Thank you greatly for your help. Hopefully this will fix the check engine light and the other issue on it.
 
1 - 5 of 5 Posts
Top