Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
The other day I went out and put something my car's trunk, no issues - it unlocked and could be opened when I get near to the car. Went for a short walk and was planning on running to the store so as I was walking up I hit the remote start. I heard a sort of weak honk, the car did not start and the headlights were sort of halfway on. At that point the car wouldn't recognize my key fob and the doors wouldn't open, so I used the tiny key in the fob to open the driver door and inserted the fob into the emergency slot on the right side of the steering wheel. The dash display sort of half flashed on, some of the dash indicator lights turned on, the dials were shaking a little bit and I heard some clicking noises. The break was locked was unable to be pressed, and I could not start the engine. The shifter wouldn't let me put it in neutral and I hear a beep and a message popped up on the dash display with a warning that the car is not in park (or something along those lines). I ended up taking my wife's car the store and as it was late I decided to address things more today. Thinking the battery was dead I tried to jump it this morning to no avail - still getting the exact same response as yesterday. Some dash indicator lights turn on, hear some clicking, no headlights, no interior lights, no power locks, no trunk access, etc. All battery terminals are clean and tight - this is the first indication of an electrical issue I've seen on it.

I'm planning on having AAA tow it to the dealer this week as they're closed for the holiday weekend but wanted to see if anyone has experienced anything similar or has a good idea of what's going on.

Any suggestions are welcome - thank you!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
not sure - I've never replaced it and got the car in October 2016. It doesn't like look old or anything but that doesn't mean it isn't I suppose.
 

·
Registered
2006 ZX3 2.0, 2006 ZX5 2.0, 2004 ZX3 SVT
Joined
·
1,188 Posts
not sure - I've never replaced it and got the car in October 2016. It doesn't like look old or anything but that doesn't mean it isn't I suppose.
4 years is about average for battery life on a ford.
 
1 - 4 of 4 Posts
Top