Focus Fanatics Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
291 Posts
Discussion Starter · #1 ·
1.) Since my 1st oil change at 3,000 miles my 2012 Focus Titanium has used oil (not leaking) at a rate of 1.25 qts. per 4,000 miles. My current mileage is at 7,000 miles. Is this normal break in oil usage for the engine?
2.) Since new, this Focus has lost the computer and driver's seat control, both now replaced.
3.) Most annoying is the hypnotic humming sound I hear between 55 and 70 MPH from the driver's front side of the car. Over 70 and under 55 MPH it disappears. Ford cannot find the cause.
4.) My gas cap cover keeps popping open while driving.
5.) The window side posts plastic trim, on both sides, dimples where attached to the body of the car. This is especially noticeable in hotter sunshiny weather.

Is anyone else having these problems or am I overly critical of my new $28K 2012 Focus?
 

·
Registered
Joined
·
157 Posts
yea I have noticed the dimples on the black plastic, my selectshift, shifts up for me sometimes, the transmission has slipped about 7 times, have to go from selectshift to drive to get it going again, my touch has froze up and my paint SUCKS, i see dark sports (more paint) on the seams of the car and light spots (less paint coverage) on major panels, some pots i can see the greyish of the primer.... not to happy at this $28,000 car !!!
 

·
Registered
Joined
·
73 Posts
I dont have those issues :\ I kinda can understand what you're saying about the humming at 55-70 but i believe its just from the gearbox it smoothed out the longer ive driven the car. I'd say hit up your dealership pronto, theres a reason why you got that warranty!
 

·
Registered
Joined
·
291 Posts
Discussion Starter · #5 ·
Do you have the same issues with the high/low humming noise it drives me nuts at around 60 MPH, even with the radio on? I never noticed it prior to the one Touch system going out. When that happened, it was quiet in the car and you could hear the noise. Now it is so bad you can hear it with the radio on while moderately loud. We tried all the tire stuff, it did not help.

I have had it in on warranty. Their techs hear the noise too. Ford replaced the wheel bearing to no avail. I think it has them stumped.
 

·
Registered
Joined
·
291 Posts
Discussion Starter · #7 ·
I have not had any paint issues I guess the paint preparation equipment was working well the day mine was painted. It could also be contamination from the bath prior to the paint booth system.

I have to admit I am not very pleased to have such cheep stick on fasteners used on highly visible external body parts made of thin plastic used for the window trim of my Focus. You would think Ford could come up with a better way to take care of this problem. You may have noticed that the plastic they are mad with scratches very easily. The only thing my Focus has seen to clean it is a well-lubricated soft cloth when being washed and dried. These side posts have all kinds of scratch marks in them making me wonder what they will look like in two years. I personally think the plastic is too soft and would be surprised if it meets Ford’s specification for this application. When I talked about the problem with the dealer, their pat answer was that all were like that, CAN YOUBELEAVE IT?
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top