Focus Fanatics Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi, I'm new to this forum and I've tried searching for my problem in the forum, googling, I was even in touch with Ford Assistance but all they did was refer me to contact a mechanic on Monday.

So my problem is that today after fueling up, the battery light popped on, took a minute or two after I had started the car. I drive a flexifuel car since a few months back, and last time I had to fill it up I also encountered problems.

To start from the beginning, I bought a Focus a few months back, we were going on a 2 hour ride and had to stop to fill it up. This was when ethanol was still a cheaper choice per kilometer here in Sweden. So now I went from using gasoline to ethanol, the car had probably never used ethanol before I bought it. So what happened, the next morning having arrived the night before. Went to the car, it started but would stall and shut off after about 2 seconds. Nothing helped, jumper cables, starting procedure.. Ended up calling Ford assistance (on extended warranty), they towed the car to a Ford mechanic and got train tickets back home instead.

The mechanic first thought was faulty cables, took a week for them to arrive, no dice. He finally figured out there was an issue/bug with the 2011 Flexifuel when switching fuels. He updated/changed something with the software and since then no problem starting with the ethanol in the tank.

Today I was using with no problems earlier and went to the gas station. After I had filled it up with gasoline the battery light came on. And it has kept coming on, a little delayed, up to a minute after I start the car.

Mind you, the first problem occured when I went from gasoline to ethanol. Now I did the opposite, I wanted gasoline due to cold weather and the price. Immediately after I switched the battery light problem occured.

If anyone has a clue what's going on I'd be very grateful. I'll still be calling the Ford mechanics on Monday, but that's a long day away and I'd like to soothe my nerves...

/Carl
 

·
Registered
Joined
·
472 Posts
Sounds like a coincidence to me. Perhaps you have a dead battery or alternator issue. Can you check the battery? Auto stores in the US check them for free, dont know about your neck of the woods.
 
1 - 2 of 2 Posts
Top