Focus Fanatics Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I am having an issue that I feel mimics the IAC valve needing cleaning or replaced. However I don't think the 2010 has it if I am correct? Sporadic idling suddenly, mostly with air on. Will idle down , then up and then hold for a bit, then down again.. Stalls a time or two. With throttle it runs perfectly. So Im naturally thinking IAC, but I don't have that so maybe I need the throttle body cleaned. I should mention I bought the car with 120K on it 2 weeks ago. It had been sitting for a year so I put in fresh gas, new rotors, pads and calipers, new battery, new oil change, recharged ac, etc.. and it had been running perfectly until this happened today. We bought it for my Mother N law. Any suggestions greatly appreciated!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3 (Edited)
Thanks pbfoot, thats what Im thinking will be the first steps. And simple enough to do, Thank you! My inlaws car is a 96 toyota with 260K on it and just everything not working, no air, only 2 windows roll down, eats oil, etc.. So we got this for her and it has been perfect in all ways since We got it back on the road and we drove it for150 miles or so with it running perfectly and she came to pick it u p last night and the whole idle thing started.. My luck..L
 

·
Registered
2006 ZX3 2.0, 2006 ZX5 2.0, 2004 ZX3 SVT
Joined
·
1,267 Posts
Thanks pbfoot, thats what Im thinking will be the first steps. And simple enough to do, Thank you! My inlaws car is a 96 toyota with 260K on it and just everything not working, no air, only 2 windows roll down, eats oil, etc.. So we got this for her and it has been perfect in all ways since We got it back on the road and we drove it for150 miles or so with it running perfectly and she came to pick it u p last night and the whole idle thing started.. My luck..L
Old cars need work occasionally. Still better than car payments. Check out the fuel filter as well.
 

·
Registered
Joined
·
4 Posts
I actually started to experience that. Initially thinking it was about time with 140k miles that it was time for a tune up. It got better but idle was as described and ended up buying the throttle body with all the sensors. It was simple and worth every penny. Car runs like new. Found out that this is a common issue with the car.

I followed this video "Ford Focus & Transit Connect P1235 Electronic Throttle Body Replace" by FordTechMakuloco and his PCM relearn procedure and now I don't have the issue and idles like new.
 

·
Registered
Joined
·
659 Posts
mine 2008 146,000 miles started doing it aswell. I cleaned the throttle body and the mass air flow senser they sell a cleaner for it. Its better but still hunts for the idle. No iac on these years
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
I just wanted to follow up on this, as one of my biggest pet peeves as a member of several truck and bike forums is someone requesting help to solve a problem and never following up.
So I took advice above and cleaned the throttle body, It had sorta seemed to self correct a bit. Cleaning the TB helped it further. It now idles normally. I just wanted to state it only did it when the AC kicked on. Now witht he AC on, it remains pretty constant. Thanks for the helps guys,
 

·
Registered
Joined
·
659 Posts
Feel the same it helps others to post results to let them know there on the right track. my next move will be replace t.b. like posted above. If it gets worse.
 

·
Registered
Joined
·
4 Posts
yeah replacing it with that link in the video, send you to the right part number. I has the body, TPS, IAC, the only extra I did was clean the MAF, with the proper cleaner. I had issues with my remote start, where it would stall and would idle very close or slightly about 1000, now remote start it never stalls and I idle roughly about 6-800. Well worth the $200 and 15 mins to install.

After the cleaning did you reset your PCM so that it can relearn the idle?
 
1 - 11 of 11 Posts
Top