Focus Fanatics Forum banner

1 - 12 of 12 Posts

·
Focal Distortion
Joined
·
2,332 Posts
Discussion Starter #1
OK everyone, here is the issues I have been dealing with over the last few months. Starting back in the summer time I was getting a random P0451 (Evap Emissions sensor) code, mostly on cold start-up. I would clear the code and it would not come back for a few weeks. more recently it has been coming up often, but there is no drive ability issues. Again P0451 code. Being as I am close to the end of my warranty I though I would take it in to Ford and have them look at it. First thing I did was load the stock tune back in the car, why take the chance right? That of course cleared the code and I had to drive a few days to get the code to reappear. Yesterday it came back on only this time I also had a P0455 (Gross evap leak). I took it to the dealership and told them about the 2 codes (p0451 & P0455). They informed me that evap was no longer under warranty and it would be $99 to run the tests on the car! So I agreed to have them pinpoint the problem for me (so I could fix it myself). after an hour of waiting the service guy came back and told me I have an electrical short somewhere along the FPT (Fuel Tank Presser) circuit. The exact words are

TEST EEC SYSTEM, 1.0, HAS SHORT SOMEWHERE IN FTP CIRCUIT BETWEEN PCM & FUEL TANK PRESSURE SENSOR, WILL HAVE TO TRACE OUT CIRCUIT & REPAIR SHORT & RETEST FOR ANY DAMAGE TO PCM AFTER REPAIR 8.0 HRS ESTIMATE $1099.00

After getting home I now have a different CEL code (P0453), this is getting annoying!

So my questions to everyone are, 1 has anyone experienced this and 2 does anyone have a diagram of the fuel pressure circuit for a 2010 S Sedan?

Thanks in advance

Bob
 

·
Focal Distortion
Joined
·
2,332 Posts
Discussion Starter #2
Nothing?????
Does anyone know where I can find an Electrical Diagram for a 2010 Focus, S, Sedan?

Thanks
 

·
Focal Distortion
Joined
·
2,332 Posts
Discussion Starter #4
Thanks Ill check it out.
Does anyone have a PDF of the Fuel Tank Pressure sensor wiring, from the PCM to the tank.
 

·
Focal Distortion
Joined
·
2,332 Posts
Discussion Starter #5
Ebay is it

Search words

Ford Focus 2010 wiring manual

Cheapest is ~$30.00
Just got one for $22.70!!

Thanks, now when someone else needs electrical help I can help them out.
[cheers]
 

·
Registered
Joined
·
20 Posts
TEST EEC SYSTEM, 1.0, HAS SHORT SOMEWHERE IN FTP CIRCUIT BETWEEN PCM & FUEL TANK PRESSURE SENSOR, WILL HAVE TO TRACE OUT CIRCUIT & REPAIR SHORT & RETEST FOR ANY DAMAGE TO PCM AFTER REPAIR 8.0 HRS ESTIMATE $1099.00

Bob
Did you laugh in his face when he quoted you that price?
 

·
Focal Distortion
Joined
·
2,332 Posts
Discussion Starter #7
pretty much!!!
I politely asked that he give my car back......NOW
I think I could take most of the car apart in that much time!
 

·
Registered
Joined
·
131 Posts
Vehicle is less than two years old, yet the emissions control waranty is no longer in force??? Sounds very strange. Did you ask for proof (documentation) that that is true?
Good luck,
Monoblanco
 

·
Focal Distortion
Joined
·
2,332 Posts
Discussion Starter #10
Yep car is less then 2 years, but over mileage! Emissions equipment is covers for 5years or 50,000 miles, I'm at 53,XXX miles. I should have taken it in about 2 months ago when I was under 50k. But I didn't because I thought it was 5/60k on emissions!
 

·
Focal Distortion
Joined
·
2,332 Posts
Discussion Starter #12
Update

Ok here is an update to the problem.
I got a Ford Wiring Manual from Ebay, so that's a good start.
I was able to find one problem so far, the harness under the back seat on the pass side goes through the body to the fuel tank. I popped the back seat out and low and behold bad wiring!



Now I have never, ever touched the main wiring in my car and there is no reason the harness should look this way. The cover was pulled back and removed, and 2 of the wires were pierced and making contact with the body. I also noticed a repair in one of the wires as well. I repaired the wires and recovered the harness in electrical tape. After that I reset the codes and about 1 min later i got a code again, P0453 (evap sensor imput too high). now off to find the rest of the issues!
[scratch]
 
1 - 12 of 12 Posts
Top