Focus Fanatics Forum banner

2010 SE chugging feeling at 45-50 mph uphill only

2011 Views 101 Replies 8 Participants Last post by  rockloop85
Bought it used, 140k. Nearly perfect condition and very clean. All of a sudden it will sort of surge, feels almost like towing a trailer that's pulling back over and over. On off on off on off. It will only do this at 45-50 mph and only in top gear(4th) WHILE going uphill. Like it's stuck deciding about going to third or staying in fourth. If I give it a tiny bit more throttle and make it downshift to 3rd, the problem is gone. If the hill is long enough that I can accelerate in fourth past 50mph the problem stops. This is our only family capabile car and need it to keep going at least till 200k to get our money out of it.
The transmission temp stays around 145-155* F

Besides that, only issue is ABS light.. The code says faulty replacement part or connector dirty (I don't remember the code but I read the light with ForScan).

Everything else is fine no other codes.
1 - 20 of 38 Posts

· Registered
Joined
·
38 Posts
Discussion Starter · #11 ·
You can have misfires without throwing a code. The "NM" PID in the bottom right of my dashboard is number of misfires. That's the first thing I would look at.
Ok I'll set it up. I'm not off again until Friday night, I'll do it this weekend. It doesn't feel like it's misfiring but hopefully I'm wrong and it's something simple.

I've never used the PC version, I've got it though. It looks similar to Android?
 

· Registered
Joined
·
38 Posts
Discussion Starter · #16 ·

· Registered
Joined
·
38 Posts
Discussion Starter · #21 ·
Next time you are in the same area, simply switch the overdrive off and see if you have similar symptoms. Let off the gas first, push the overdrive off button underneath the left side of the shifter knob. Did you replace the spark plugs? If the coil pack rubber was wet with oil it is a good idea to remove the coil pack rubbers and clean with electrical degreaser.
Yes with overdrive off it won't do it, same as giving it just enough gas to downshift. It happens faster than I've ever felt this transmission shift... On off on off on off. With each "on" feeling like a trailer is pulling the car back. Almost like an underpowered car having the AC compressor turning on and off. I'm finally off this weekend and now have some direction from all of you that I will go in. I'll keep you all updated.
 

· Registered
Joined
·
38 Posts
Discussion Starter · #22 ·
I tried. Looks like it should work:

D:\download>fc /b v1.pcm v1.txt
Comparing files v1.PCM and V1.TXT
FC: no differences encountered
Thank you. I just checked out my laptop has Bluetooth.. Never had to pair anything to it before.. And it does in fact have bt. I'll have the car at home this weekend to data log.

I wonder if that file format works with Android, I've got a spare phone.
 

· Registered
Joined
·
38 Posts
Discussion Starter · #25 ·
I know vLinker FS USB adapter works with Windows, I use it. Not sure about Bluetooth adapters and Windows. I don't see any BT adatpers recommended for Windows on the Forscan website. Under "Supported platforms" it says

Windows 2000/XP/Vista/7/8/8.1/10 (ELM327-compatible adapters with COM, USB, Bluetooth and WiFi interfaces, J2534 PassThru

But earlier on the same web page, it says:

we do not recommend any "ELM327" anymore. If possible, please use adapters recommended above (OBDLink, vLinker). FORScan will continue to support ELM327 adapters, but some new functionality may be limited or refuse to work on outdated adapters

So if your BT adapter is an ELM327-compatible adapter, but not on the recommended list, it's not clear to me if it works, or how well.

You'll be the expert.
I've got a cheap elm327, those blue colored ones all over Amazon. Hopefully it'll work, it does for my phone I just get a message saying it might give issues but it never has. I'll know tonight or tomorrow afternoon
 

· Registered
Joined
·
38 Posts
Discussion Starter · #26 ·
With stumbling or rough running, misfires are possible. If you can check the misfire PID with your phone, might save some time setting up Windows.
Sorry for taking all day for this....that hurricane is supposed to pass right over my house on Wednesday and I've been getting things ready. I did this data logging while searching for a gas station that wasn't sold out! Found one with premium only..50$ for 11 gallons lmaoooo. At least the tank is full.

So i've got two different ones. One is idling while warm. And the other is driving uphill while the chugging happens. The third file is the set of specific modules i'm looking at. Not all of the ones you've got were available for our car.

The FordFocus1.txt needs to be changed to .allmods
idling.txt needs to be .fsl
uphill.txt needs to be .fsl

I don't think anything stands out but you tell me. If there's another module you want to see let me know and i'll look if its available.
 

Attachments

· Registered
Joined
·
38 Posts
Discussion Starter · #28 ·
Shit it was late and I wasn't thinking. I tried to load your. Pcm file but it wouldn't work even renamed to allmods, no luck. I searched for all of your pids in the "all" folder, not just "pcm" and selected the ones that were the same and similar. Others I added thinking it might be important.
On the recording, it's between 8 and 22 seconds and stops after throttle position drops down from 67%.... That's the car getting over the top of the hill and going back to idle.
I'll post two images of right before the problem and the end, they are separated by about 10 seconds.
If there's any other pids you want me to log let me know and I'll search for them.
 

· Registered
Joined
·
38 Posts
Discussion Starter · #36 ·
Hey all, haven't taken the car and laptop out. Been preparing for this hurricane heading to Florida. I'm near Tampa and soon it will be too 🙃. Thankfully we've got storm shutters and a generator (that we've had since hurricane Andrew!) That I just rebuilt the carb on. She purrs like a sewing machine (a very loud one).

And bcat, which pid is NM?
 

· Registered
Joined
·
38 Posts
Discussion Starter · #40 ·
Stay safe my friend

The whole state of Florida North of Tampa (all the way through Lake city) to the Georgia state line is a glorified trailer park.

Not too many of those things can handle 120 mph winds.
Lol I'm north of Tampa. You ever heard of where the mermaids swim? Thankfully my corner of town is deed restricted so my home is of normal construction. I'll admit there's a bunch of trailers around. And IDK how old everyone is but I was in Miami during hurricane Andrew. Parents house was fine in Miami shores but our family in Homestead, that entire place was completely leveled. They were all prefab and mobile homes. After Andrew it looked like a war zone, but that was category 4-5. If this one stays below a 4 then I'll sleep pretty easily.

And I'll be parking the focus as far from trees as I can.
 

· Registered
Joined
·
38 Posts
Discussion Starter · #41 ·
Number of misfires (PCM module). It guides where we look next. Maybe 0, but let Forscan prove it.



The car can wait. Stay safe as you can.
so the hurricane completely missed us. grateful it did, it was pretty bad for south florida.

heres the table of the PIDs i was watching most recently. this is right at the time i felt it.
this picture shows missfire at 1610rpm, that was right after a cold start before driving to the hill to replicate and log

Font Number Screenshot Parallel Rectangle

and this is from last week, right as i felt it again.
Font Number Screenshot Parallel Document


i hope this helps
 

· Registered
Joined
·
38 Posts
Discussion Starter · #49 · (Edited)
All valid but I guarantee the spark plugs have never been changed. He never answered any of my questions. I'm out.
All valid but I guarantee the spark plugs have never been changed. He never answered any of my questions. I'm out.
was told plugs were done along with valve cover gasket and motor mount right before purchase. monday i'll be able to pull them and ill take some pictures. I did remove the coils and theres no oil to be seen floating around.
 

· Registered
Joined
·
38 Posts
Discussion Starter · #52 ·
. I did remove the coils and theres no oil to be seen floating around. i'll have pictures of the plugs monday, tuesday at the latest.

Turning overdrive off unlocks the torque converter, drops it to 3rd and will lock the torque converter if I'm not accelerating or going uphill. the problem does go away. I've also driven up that hill at the same RPM with OD off as i would with OD on, about 1700 and under 40mph and theres no issue. A miss is a random feeling, this is not. If theres a specific PID you'd like to see or something you'd like me to do (besides plugs, those ill pull out monday) let me know so i can try it.
 

· Registered
Joined
·
38 Posts
Discussion Starter · #59 ·
All the foci I have owned have been manuals so fill me in here... is 4th gear overdrive?
Does the car have a tach? It would seem to me an important piece of info would be what kind of rpm he's doing at this 45-50.
It's not unreasonable at all and possibly prudent to be in 3rd gear on the hill.
My wife and I traveled from NW Washington to mid California last year and even using the freeway there are "hills" that require 3rd gear with the 5 speed.
4th for this year is the highest gear, then the torque converter locks for the lowest rpm. This happens about 1700rpm. I'm posting pictures under this reply of the plugs and coils.
 
1 - 20 of 38 Posts
Top