Focus Fanatics Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My girlfriend has a 2009 Focus SES with 45k on the odo. Our issue is with the radio display not showing up. It worked last about 3 days ago and we havent had an issue before. Untill one warm day we went for a drive and it didnt show up. No lettering or back lighting. The radio and all of the controlls work properly just a bad display. Checked all fuses and wondering what ww should do next. Thank you!
 

·
Registered
Joined
·
5,887 Posts
My girlfriend has a 2009 Focus SES with 45k on the odo. Our issue is with the radio display not showing up...
Hi njdevils1990,

Have you considered swinging by your dealership so they can take a look? They're an excellent resource for getting concerns like this one quickly resolved. Let us know how things go moving forward. :)

Crystal
 

·
Registered
Joined
·
2 Posts
2009 Focus SES Display Blank

I have encountered the same problem and was wondering if anyone has found the solution. I did call my local Ford service department and they offered little help, they would not try to diagnose and fix the problem, they said the only thing they would do is replace the entire radio for about $500.

I have checked all of the fuses, and inspected the battery for corrosion. The radio itself still works just fine, but the display just went blank so I cannot see the radio station, time, compass or outside temperature.

Any suggestions?
 

·
Registered
Joined
·
5,887 Posts
I have encountered the same problem and was wondering if anyone has found the solution. I did call my local Ford service department and they offered little help, they would not try to diagnose and fix the problem, they said the only thing they would do is replace the entire radio for about $500.

I have checked all of the fuses, and inspected the battery for corrosion. The radio itself still works just fine, but the display just went blank so I cannot see the radio station, time, compass or outside temperature.

Any suggestions?
Welcome to the forum!

I want to see how to best assist; can you please let me know your mileage?

Meagan
 

·
Registered
Joined
·
5,887 Posts
135k miles. Does the radio have a mileage limit?
No, but it's part of our process to ask. Have you gone to another dealer for a second opinion? You can find all the dealers in your area here: Dealer Locate.

Meagan
 

·
Registered
Joined
·
1 Posts
Did you ever get the issue fixed with the display? I just recently bought a used 2010 Ford Focus and after 1 day of owning it the exact same thing happened with the display.
 

·
Registered
Joined
·
2 Posts
Sorry to poke at an old thread, but one thing I'd try is pop up the plastic hood above the display, it's just held on by pop-off/on tabs. Take a look behind the screen once that's off and inspect the connections, something may have simply rattled loose.

The only reason I'm here is because my radio screen did this once last night and I'm curious if it's a common problem. I had my radio off, so it was just the clock in the middle of the screen, and when I parked it turned off for 10 seconds and then came back on its own. Weird! If it happens again the first thing I'll do is check those connectors.
 
1 - 9 of 9 Posts
Top