Focus Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
A couple of months ago and started getting a creaking sound and ride degraded to the point if felt like a out of balance rim at highway speed .

I have brought it to several places and the Ford dealer none could find a problem I mentioned to the dealer about a TSB but since i was at 56k no help in finding my problem.

I replaced the the sway bar links it help a little still vibrating at speed creaking started a again so I replaced the upper strut mounts it help with vibration and ride but while turning and wavy bumps I still have the creaking possible the links are shot again ?
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #3 ·
everybody who looked at it said it was sound I'm leaning toward struts i really think it could be the end links since they are ford links
the creaking sound is always with bumps i think if it was a arms it would be constant ?
 

·
Boosted HB.
Joined
·
1,698 Posts
i just replaced my end links because of a clunking noise when i went over bumps. I just got back from a drive and the clunk is gone.


I still have this creeking noise and I know its the a arm bushings. Going to replace those next!
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #8 ·
is the Moog parts any good?
I would say i have not the best of luck with them I had all of the boots split
dirt some how got inside and they started to become loose .
Would i buy them again sure maybe extra protection wrapping the boot with a zip tie .

The raybestos end links visual seems like better protection for the balls but i didn't research it for pro and cons
 
1 - 8 of 8 Posts
Top