Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My 2007 zx4 has started making a loud rumble in reverse that gets louder when the break is applied, anyone else have this issue? I'm not sure if it means reverse is going out or what but it really doesn't affect the way it drives. I would just like to figure out why its making the rumble and how to get it to stop. Also when I accelerate hard and turn at the same time my power steering starts to whine for a moment. Fluids are where they need to be so is it just time for a new PSP? Thanks in advance
 

·
Registered
Joined
·
3 Posts
I would replace the PSP if it made noise. In fact I did, but I knew for sure mine was bad. And don’t trust the PSP pressure sensor. Mine didn’t throw a code but it had almost no pressure in the line.

How does your steering feel? Easy turning or is there some resistance turning the wheel?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I would replace the PSP if it made noise. In fact I did, but I knew for sure mine was bad. And don’t trust the PSP pressure sensor. Mine didn’t throw a code but it had almost no pressure in the line.

How does your steering feel? Easy turning or is there some resistance turning the wheel?
Yeah mine isn’t throwing a code or anything. I’ve checked everything and all seems to be fine as well as my steering is easy as can be. The only times it makes the noises is when I give a little too much gas from a stop
 
1 - 3 of 3 Posts
Top