Focus Fanatics Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi all, I'm new on here so apologies if this has been asked.
I have a 2006 Focus and the drivers side rear indicator stopped flashing. This happens with the hazards too. That side now flash faster!

I changed the bulb to a new one but the problem remains. I checked the new bulb and it seems ok (there's continuity there when I put the meter on).
I then checked the contacts in the unit and there's no power getting too it.
I'm pretty sure it can't be a relay fault as all other lights are fine, but I don't have a manual and cant find out which fuse might be blown.

Anyone got any ideas?

Thanks in advance.
Davey!
 

·
Registered
Joined
·
60 Posts
Is the capacitor possibly faulty? I know that capacitors charge up then pass a burst of energy then charge up again, thats what causes the flashing light (I think).. not the surest on light electrics though. Hope you get it sorted anyway!

Sent from my GT-I9300 using Tapatalk 2
 

·
Registered
Joined
·
3 Posts
I had the same problem and dont really know how I fixed it.. but I did. What I did, Removed all bulbs, Gave all electrics a good spray, Replaced bulbs, Checked all fuses, more spray with wd40 or something similar. While messing Something I did sorted it. What I dont know.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Thanks, I'll give that a go. I haven't really had time to look into this. I was just hoping it was something that had happened to others so I could get a quick fix. I'll give it a good looking at after work and post my findings. In the meantime.....all guesses are welcome.
Cheers

Davey
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
Update.
Checked all fuses and they are all fine.
Took the plug off the bulb and the meter showed continuity between the two prongs of the plug. It looks like the live is being earthed somewhere. I tried tracing the wires back but only got as far as the boot!
Without a wiring diagram I don't think I have much chance of finding it.
I might need to call an auto electrician.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
Update.
auto electrician says it's the Body Control Module, will cost £150 to fix. Already cost £25 for diagnosis!
Anyone know where I can get a BCM cheap?
 

·
Registered
Joined
·
12 Posts
In other cars I've owned, I've often found this can be just a bad contact at the point the bulb screws in. Try removing the bulb and cleaning the contact points - it may save you a few quid mate
 

·
Registered
Joined
·
8 Posts
Discussion Starter #12
Thanks, but unfortunately, after a £25 computer diagnosis, this turned out to be the Body Control Module. It cost £150 to repair!!!
I looked into fitting a one from a scrapyard etc, but apparently you have to upload the cars' info to a diagnostic computer, then wipe/repair/change the BCM, then download the cars info back into it.
I yearn for the days when we replaced a £5 flasher unit.

£175 to fix a non flashing bulb.................I wouldn't care, I know where 'I'm' going.............this was for your benefit!!!!!!!!!!!! [driving]
 

·
Registered
Joined
·
1 Posts
I've got a 06 focus in AUST . When the weather is hot .over 38deg the left hand indicator sometimes turns on by it's self and won't turn off even if I disconnect the indicator wiring . Running out of ideas .HELP
 
1 - 13 of 13 Posts
Top