Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
hello,
new to the forum and first post, tried searching for answer to my problem but couldnt find anything. straight to the problem.

So i was driving normally, third gear, break to turn and change gear and as soon as i press the clutch pedal halfway i hear a small bang and my heart sinks. release the pedal and hear a rattling sound, the sound goes away when the pedal is depressed, the car is moving but making noise and not enough power going to the wheels, instantly i know its either the flywheel or the pressure plate and time to get a new clutch, i press the pedal a few times, drive the car to reach home and on the way the noise goes away, no more rattling sound, the car is working fine, but now it has fallen to what seems like half power. so asking a few mechanics and a clutch expert they all say the obvious the clutch is gone, so i get a complete new clutch kit with flywheel. everything done and the car still is working at half power.

rev up the car, doesnt give any smoke, engine sounds normal, no sound during running of the car. Stumped i cant figure out whats wrong. Any help would be greatly appreciated, this is my first focus and love it a lot. Am gutted right now.
 

·
Old Phart
Joined
·
44,596 Posts
Moved to General Tech Chat for a better location (added "maybe" to the title as well).

Sounding more engine related to me, but few on here are experienced with Focus Diesels.
 

·
Registered
Joined
·
1,187 Posts
Is it revving up but not moving much, i.e. the clutch feels like it's slipping still?
Or is it that you can't get much accelerator response?

Did you change the slave as well? How about the master?
 
1 - 3 of 3 Posts
Top