Focus Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I am running out of ideas to start off with I am new to the ford world.I can idle up to 30mph without hitting gas .. And right now I am averaging 13mpg
 

·
FF Affiliate
Joined
·
31,087 Posts
My first guess would be a Vac leak , check the hose going from the intake to the PCV line , rubber hose bad to go bad , check other Vac lines on/from intake as well

Tom
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Ya its stock tb and I think it does close all the way when I unplug the idle air control valve it drops the rpms down I think (no rpm gage) before I changed the hose it would idle up and down and then die googled it then replaced hose it stopped that but now just idles very high and when I stop at red lights it wants to surge forward and when I put it in park it spikes dramatically But it won't let me run without the idcv plunged in sadly but I did drive it with it unplugged and it still idled up to 25mph
 

·
FF Affiliate
Joined
·
31,087 Posts
Still sounds like a Vac leak to me , do you know of anyone that has a Ford SCT xcal that you can barrow , would be glad to set up and look over a log for you

Tom
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
God I wish I could get ahold of one and I do have a check engine light on now autozone told me it was cause of cat
 

·
Premium Member
Joined
·
44,595 Posts
Moved to General Tech Chat, not really performance tuning questions so you'll find more info. here.
 
1 - 10 of 10 Posts
Top