Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter · #1 ·
Hi all,
today our(up to this point) impeccably reliable 2004 2.3l zx5 stalled while my wife was driving it. SHe was driving along and the engine just cut out. No loss of power, hesitation, nuthin. She didn't even realize it had stalled as it usually runs so quiet. It started right up for me, and i drove it back to work. Here's some pertinent info:
2004 2.3L PZEV automatic
~53K miles
no mods what so ever
run M1 5w-30 oil and filter, pretty good change schedule(~every 4000 miles) got about 1500 miles left on this oil
over 1/2 tank of gas
Battery has green dot, no lights came on prior to the stall
temp gauge reads normal
Wear indicator on stupid factory airbox shows green with engine running
oil smelled normal
tranny fluid smelled normal
started engine, set pbrake and foot brake and bogged engine in reverse and drive, engine recovered smoothly and maintained idle(I thought maybe IAC dropped the ball)
I got it on some empty back roads and reemed out a little, and it had all the power and smoothness that it's ever had.
No knocks, pings, clanks etc

Most recent work:
put new rims and tires on this week, replaced 16's with 15's
oil change a few weeks back done by me

What i'm thinking to look at this weekend:
Check bat cables and all harnesses, chk alternator cabling.
Get charging system tested at autozone
Check water level in batt if i can get the caps off
reset ECU

Any ideas or suggestions? Am i on the right track, or chasing shadows? let me know what you all think, thanks!

--chris
 

·
Registered
Joined
·
525 Posts
im pretty sure all foci have stalled at one time or another. shouldnt be anything to be concerned about unless its happening quite often.

what you've checked for so far seems about right. if no codes or lights popped up i wouldnt be too concerned.

-Joe
 

·
Registered
Joined
·
34 Posts
I actually just stalled mine the other day. I didn't put the shifter all the way in drive and it popped out and stalled. No biggie. If it keeps stalling, then you'll have a problem. Don't worry
 

·
Registered
Joined
·
88 Posts
Discussion Starter · #5 ·
Thanks for the input fellas, i'll keep an eye on it. We drove it around alot this weekend with nary a flutter, so i suspect it was just a fluke, least i hope so. Thanks again, returning to lurker status :)
 
1 - 5 of 5 Posts
Top