Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys I have an 01 zx3 and my power steering reservoir bubbles over, not when I initially start it but when it starts to get warm. If I let it sit for 10-30 min it doesnt do it again till a little later. What could cause this?
 

·
Registered
Joined
·
1 Posts
Has the pump run low or dry? My Focus developed a pretty substantial power steering leak, and once or twice before that was taken care of I had to drive to get power steering fluid with that telltale squeal. Ever since I've had similar symptoms to yours, although the actual power assist on turning the steering wheel doesn't seem to be affected.

Once in a while there's even a little smoke billowing up from under that side of the hood - although whether that's from the power steering system, cooling system getting a little too hot, or just something I spilled last time I was under the hood I couldn't tell ya.

Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Has the pump run low or dry? My Focus developed a pretty substantial power steering leak, and once or twice before that was taken care of I had to drive to get power steering fluid with that telltale squeal. Ever since I've had similar symptoms to yours, although the actual power assist on turning the steering wheel doesn't seem to be affected.

Once in a while there's even a little smoke billowing up from under that side of the hood - although whether that's from the power steering system, cooling system getting a little too hot, or just something I spilled last time I was under the hood I couldn't tell ya.

Sent from my SM-G965U using Tapatalk
Yeah it had a leaking coming from the pressure sensor oring had to get that fixed and it worked well for a while not it just started doing this bubbling over and idk it's just weird. I would think if I had a bad line it would do it when it first started. But it's not till it warms up a bit. Do you think maybe my cap could be bad? I would think the pump going out would do it all the time but idk
 
1 - 3 of 3 Posts
Top