Focus Fanatics Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 2001 4cyl automatic Focus. It has just under 90k on it. This was a car used by someone else in my family up until 2 years ago and now seems to be having a lot of issues. Here are the issues I have been experiencing in no particular order.

When you accelerate (and sometimes when you idle) there is a lot of vibration. I had thought it was motor mounts, but I took the car to a mechanic who said it was not motor mounts, but was the struts. The vibration still happens. One time I accelerated a lot and it vibrated so much it made something else not work ( I don't remember what it was). What else could it be except the motor mounts?

I noticed about a week ago that when I am driving, there is a slight squealing noise. It was not the noise of bad brake pads, it was kind of high pitched. Someone told me it might be the CV joints. Today, I was wiping snow off the car and had the car on warming up and running the defroster and it was making the same noise while it was idling.

The heat only works when it is on level 4 and not the other levels. My dad sent me a thing that said how to fix it (a $25 part), but I don't have a manual of where to replace it (I can't remember what it was and the thing he sent me is at home). Are there service manuals somewhere online?
 

·
Registered
Joined
·
40 Posts
I'm not a mechanic, but I do have experience with having problems with my car lol. The squealing sounds like it could be the Serpentine belt.
 
1 - 2 of 2 Posts
Top