Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Dear Focus Fanatics,

I've got a pretty killer subwoofer which I wanted to fit in my Camaro, but unfortunately it won't fit. So instead I want to put it in my daily driver, my Focus. Uninstalled the radio, but now how do I attach my amplifier to the back of my factory radio which doesn't have RCA outputs? I bought RCA cables but I'm unsure how I can best attach them to my stock radio.

Thanks in advance!
 

·
Registered
Joined
·
15 Posts
Honestly, can't help with the RCA cables, but if you have a little extra money just buy a new Head Unit. You may want to try and save money by using the factory one, like I did at one point, but it's just not worth it, if you want better quality sound. I once tried figuring out exactly what you're doing and was left nothing but confused; everyone I talked to told me just to get a new damn Head-Unit and make it easy. I waited a little bit, (Poor college student at the time) and I got a $115 Kenwood HU with iPhone capabilities and never looked back.. Running Two Kicker 12's, took a lot of maneuvering but was finally able to fit it in the trunk of my ZX4
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks, guys! But unfortunately my hands are tied when it comes to spending, so I'm going to have to work with what I got. I've now attached the subwoofer to speaker wires after removing one of the hind speakers to free up the cables. Would it work to put an amplifier inbetween or am I dealing with the wrong end of hi/low here?
 
1 - 4 of 4 Posts
Top