Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hi all

I have a problem that I would be greatful for any help.

My focus is a 1.8 TI Endure engine. 1999

It will cut out after 30 - 60 mins as if its run out of diesel and will turn over but not start until its cooled down.

Its a bit of a nightmare when I break down cos I know il be sitting there for over an hour before she will start again.

I have been told its the fuel pump and will cost around £1000 to fix. To be honest I will have to scrap it if its going to cost that much and polish up my push bike to use instead.

Any ideas? anyone please? could it be timing???
 

·
Registered
Joined
·
2,290 Posts
Check the cam shaft position sensor, a new one is about 15-20GBP and takes about 10 minutes to change it.
I would have your service tech put a new cam shaft sensor first before being talked into a new fuel pump.
Could be a quick cheap fix.
Seems a very common problem, do a google search you will find many threads on this same problem, with the
cam shaft sensor being the problem.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3 (Edited)
Thanks for your response.

I have changed the crank sensor and cam sensor, I ordered the cam sensor from Ford and they said the TI does not have one???

But sent me a sensor anyway, its a brass looking sensor with a plug and 2 wires coming from it. It screws in the back of the top of the engine. Think its a heat sensor??? Fitted that and had engine service still no luck.

It starts when cold and will run for up to an hour then cut out. Then won't start until temp gage is all the way back to the cool.

Anyway, anything else I can check or get checked. As I said, been told by diesel specialist that its the fuel pump. I want to try every thing else fist because I really can't afford to spend that sort of monies.
 
1 - 4 of 4 Posts
Top