Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
I have an 04 ZTS 2.3. Automatic. This morning on the way to work I mashed the throttle and dropped into third and noticed the tack was kinda jerky like a surge almost.....took it easy after that because I wasn't sure what was going on. On the way home today it acted like it was running out of fuel.....I could keep it at a steady speed and get along pretty good but ended up just getting slower and slower until it finally died on the side of the road. Cranked on it and no start, few minutes later it started just fine, accelerated fine up to highway speed then the same thing all over again. Let it sit, then crank and go. One time I pulled over to swap the fuel pump relay out and the relay was kinda hot....seemed hotter than the others, accelerated to highway speed but still felt and saw the tach surge then slowed again as before

Additional info: Fuel pump is 3 weeks old, new battery, plugs 6 days old
Did NOT replace fuel filter or fuel pump driver module.

Daughter and her boyfriend have driven it and said it "bucked" on a few occasions but give it some throttle and it goes away. It has bucked on me once.

Also, at idle it appears if the Alternator may not be charging enough. The dash light kinda flicker until you give it some throttle. However, I haven't had to charge the battery and lights and all electrical appear to be normal. I did notice it didn't matter if I had the AC on or off on the way home today.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
Oh, almost forgot. Did get a P0171 code, lean bank 1 I think but not when the kids drove it, only today for the first time.
 

·
w/ my magic bag
Joined
·
29,468 Posts
New fuel pump, but not a filter? I'd change out the filter.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
New fuel pump, but not a filter? I'd change out the filter.
I know...LOL! I bought one, barely got under it and couldn't see the dang bolt to pull it off so I left it alone. I will be replacing the fuel filter tomorrow or Sunday A.M.
 

·
w/ my magic bag
Joined
·
29,468 Posts
I know...LOL! I bought one, barely got under it and couldn't see the dang bolt to pull it off so I left it alone. I will be replacing the fuel filter tomorrow or Sunday A.M.
You'll be surprised, when you do it.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
You'll be surprised, when you do it.
Yea, feel kinda stupid actually. All I had to do was look up. [facepalm]

Swapped fuel filter this A.M. and she runs like a new one now. You'd think they could make a filter last more than 140,000 miles. [giddy] J/K I figured it was the filter, I guess I needed some reassurance.

While I was working on it I decided this would be a good time to reset the ECU and install the Stealth C.A.I., afterward cranked it up and let it idle a bit then went for a ride. Quite impressed, the thing runs like it was new again.


Thank you felixthecat and all of FF. This site has helped a bunch.
 

·
Premium Member
Joined
·
44,595 Posts
Thanks for getting back with the solution, glad the site helped out.

Edited the thread title to match your edit, maybe it'll help someone.

Cheers
 
1 - 7 of 7 Posts
Top