Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
I have an 06 ZX4 I noticed that it seemed to take a little longer to start then I would deem appropriate. So fast forward a few weeks and over the last few days has progressively gotten worse. It’s taking a while to crank over then will stall but start back up and smooth out. No issues while driving nothing. I changed the fuel filter to no avail. But I don’t won’t it to leave me stranded. Any ideas of what to do? The car has 80k on it
 

·
FF Affiliate
Joined
·
30,611 Posts
Few things come to mind that could cause this , Vac leak , dirty IACV ,

I would do a smoke test with a cigar and start there

Tom
 

·
Registered
Joined
·
54 Posts
Discussion Starter #3
ok so I replaced IACV, the plugs because I thought I did those already but that was my prior focus, and the coil boot kit with new springs. JET (my cars name) started up like a brand new car this morning. So I’m pretty sure I got it. Now i just have to figure out this weird rattle sound. I’ve got it pretty much narrowed down to the pulley system. It was doing it only when the heat was on, and the car had to be in gear and with your foot on the brake crazy I know. It’s doing it much more I think my tensioner is cooked honestly. Once I get that straightened out it’s on to mods. Any idea where I can get the FSWerks header? There products seem to be amazing parts for this car so I’m gonna go with them. CAI, race exhaust, lowering springs, but I need a header, and I’m thinking the SCT TUNE
 
1 - 3 of 3 Posts
Top