Focus Fanatics Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I've got a question for everyone. I bought an 03 SVT and in the 1800 miles that I've had it, it has died 5 times. It has died 3 of those time just going down the road. It just dies! no warning at all. The other two times have been coming to a stop. When I put the clutch in, it dies. It's been to the dealer 3 times and they can't find anything. They even had a "Ford Engineer" fly in to look at it, nothing. Has anyone had this happen to their car? Any advice?
Thanks.
 

·
Registered
Joined
·
148 Posts
no fortunatelly it does not happen to my SVTF (02) but sometimes when i am waiting for a green light my engine looses rpm and battery lamp is flashing (so i hit gas and everything is ok after that)
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
The problems that your talking about are what they tried to fix with a TSB 03-19-11. Check it out it might take care of your problem.
 

·
Registered
Joined
·
2,516 Posts
does your state have a lemon law? if it does, i'd pursue it. this is the first time i've ever heard of this problem. have you done anything to the car?

Mike
 

·
Registered
Joined
·
10 Posts
Well, I've had both of the problem listed by RocketSVT and Bolan. I got my car brand new with 6 miles on it and by 4000 miles I had already had it in the shop 4 times. My car would do exactly as Bolan's and lose rpm as I was decelerating (with clutch pushed in) and the battery light would come on. Once or twice, it would just die in the middle of the road. After replacing the clutch, redoing my intake and a number of other things, I took it to a different dealer and they fixed it within the first 30 minutes they looked at it. They reprogrammed the ECU. One more visit and I could have utlilized the lemon law.
 

·
Registered
Joined
·
10 Posts
I don't know, the invoice doesn't say. It just says:

"...ran Oasis and found TSB 031911 Reprogrammed PCM to latest calibration level, per TSB retested OK..."

This fixed the problem with low engine rpm's on deceleration, occasional stalling, and rough shifting (which usually preceded the aforementioned problems).
 

·
Registered
Joined
·
5 Posts
Sorry to bring up a dead topic, but my focus is doing the same thing. I brought it in for them to reflash the computer, and most people don't have problems anymore after that, but mine still stalls, even if I warm the car up for a minute beforehand.

I brought it in again and now all they're going to do is put in a data recorder so that when it installs again, I bring it in so they can see what's up. I'm kind of annoyed about this whole thing and I'm glad I don't have a far commute. I usually end up stalling in the middle of a turn on a busy intersection, but since there's a light, I'm usually okay, but it's not exactly safe if I decide to make a quick turn and it stalls on me. SVT has contacted the dealership to get them to put the data recorder in. No one knows what's wrong at this point.

Just curious.. what's the lemon law?
 

·
Registered
Joined
·
1,236 Posts
I'd say it's a GOOD thing that they are putting in a data recorder. It tells me that they are paying attention to you.
 

·
Registered
Joined
·
246 Posts
one that i was gonna buy did the exact same thing. It was an 04 with about 30 miles on it. The battery also kept dying and i had to recharge it a couple times.
 

·
Registered
Joined
·
5 Posts
soffiler said:
I'd say it's a GOOD thing that they are putting in a data recorder. It tells me that they are paying attention to you.
Probably not me, but my husband who brings in his SVT cobra and they treat him like royalty. I made him bring in my focus. If I went in they'd probably ask me if I knew how to drive stick.
 
1 - 12 of 12 Posts
Top