Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Much like the other post that is on here my dash lights on my '03 svt do not work. The dimmer switch dims everything else but the backlight which leads me to believe that it's the transformer. I bought a transformer off amazon and was wondering if any of you guys have a very detailed tutorial ( pics would be amazing) on how to do this. Here is a pic of the transformer I have much thanks!
 

Attachments

·
Registered
Joined
·
4,416 Posts
I have never heard of anyone doing that on a Focus instrument cluster. Adding lighting, yes. Adding LED's, yes. Adding that rig into the existing cluster setup, nope.

What you are suggesting sounds odd, difficult or tricky to me. Hopefully someone else comes along and has some good advise, sorry I do not.

I have heard of people here that removed and cleaned the circuit board inside the instrument cluster -and- this has solved some back-light problems.

Do a search for "instrument cluster lighting". Good luck.
 

·
Premium Member
Joined
·
44,595 Posts
Read the other thread:http://www.focusfanatics.com/forum/showthread.php?t=287665

And you'll see suggestions on where to find both instructions & an inverter.

The "universal" type you have pictured I haven't seen used. That one will be more of a PITA to install as it uses it's own separate control for illumination level.
 

·
Vince your Moderator
Joined
·
5,074 Posts
I have an aftermarket inverter installed to control my cluster.
 
1 - 4 of 4 Posts
Top