Focus Fanatics Forum banner

1 - 6 of 6 Posts

Registered
Joined
5 Posts
Discussion Starter #1
I got an 03 ZX3 2.0L DOHC. Cars some mileage on it but I noticed in 4th between 1,900 and 2,200 RPM鈥檚, I start to jerk around, like a rapid fire 馃ぃ. I have a new clutch, no codes, I鈥檓 thinking it鈥檚 a fuel filter but I changed it recently. Any help would be greatly appreciated !!! Thanks
 

Registered
Joined
844 Posts
I got an 03 ZX3 2.0L DOHC. Cars some mileage on it but I noticed in 4th between 1,900 and 2,200 RPM鈥檚, I start to jerk around, like a rapid fire 馃ぃ. I have a new clutch, no codes, I鈥檓 thinking it鈥檚 a fuel filter but I changed it recently. Any help would be greatly appreciated !!! Thanks
Check your wiring pigtail to the coil pack. Check your plug wires.
 

Registered
Joined
452 Posts
Could be "tumble flaps" as well. If it's a duratec it will do that.
 

Registered
Joined
980 Posts
2003 2.0 is a zetec.
Sounds like 'fish bite' misfire which is a very common problem on Zetec due the failure of the coil pack. Remove the coil pack and examine for cracks. While you are doing that I would inspect the spack plug wires and pull the spark plugs and inspect those too. Essentially inspect the entire secondary ignition system, but I suspect a bad coil pack. My 02 Zetec wagon had the same issue (no codes) and a new Motorcraft coil pack fixed it.

Paul
 

Registered
Joined
54 Posts
I also had this with son's ZX3 and it was a combination of a bad coil and spark plug wires were soaked in oil from a leaky valve cover.

Good Luck,
Allcruisen
 
1 - 6 of 6 Posts
Top