Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have had my 02 focus for about a year or so now and a while ago while gettn on the freeway, i was getting up to speed pretty quick to catch up with traffic and i noticed the car start to jerk while accelerating. Tge best way to describe it is as if i turn the ignition on and off each time within a fraction of a second. Its still doing it. On and off mainly when you mash the throttle or 3/4 throttle. Sometimes its like it cuts out amd back on then looses only half power for a few seconds then back to normal.
SO FAR TO FIX IT:
-added grounds in case of short
-checked battery and altenator and all connections (all tested well)
-checked throttle body
-replaced TP sensor
- cleaned the IAC sylenoid
-checked plugs (need to be replaced)
-cleaned MAF sensor
Also it has an aftermarket intake system
aftermarket exhaust.
The only code i get is P0420 which is a catylitic converter emissions code.
My next thing is to replace plugs and test the ignition coil pack amd replace if needed


If those dont solve my mystery im at a loss.
any suggestions? Besides take it to a mechanic im a shadetree mechanic on a budgeot. Taking it in is last case senario. Please help.
 

·
Registered
Joined
·
4,416 Posts
Might be the coil pack or the wiring harness leading into the coil pack is damaged. This is a common problem on that engine.

Coil pack or Coil pack, not sure, maybe just the Coil pack instead.

Tiny hairline cracks in the body of the coil pack can do that.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
That was same thought it seems to affect all cylinders at the same time. I will try it thanks for the input!
 

·
Premium Member
Joined
·
44,595 Posts
There's only one power wire to the coil, and two grounds for the pairs of cylinders.

That connector or it's wiring looks like a suspect if it's totally dieing then catching.

(Single miss can FEEL pretty bad, and that points more to the coil)
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Okay having gathered more information, i need to also mention that the yellow "!" Multifunction light comes on as well when it surges or jerks while accelerating which i havent quite figured out just what that light means any info?
 
1 - 5 of 5 Posts
Top