Focus Fanatics Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter #1
when I turn the key it cranks over but won't fire, don't hear the fuel pump turn on but it was replaced 4 months ago, tried changing relay in fuel pump and then ECU and this got the car running for 6 days, now its acting up again and changing relays doesn't help and my predator won't bring up any codes
 

·
Premium Member
Joined
·
6,442 Posts
Moved to "Ford Focus Technical Chat"
 

·
Registered
Joined
·
145 Posts
Discussion Starter #6
I've checked both and replaced fuel pump relay, I't didn't help, I wonder if the fuel pump safety switch could be bad?
 

·
DTC P0606
Joined
·
3,364 Posts
Bypass the switch; it's a simple on/off button with two contacts. Check the connections at the FPDM and grounds (although problems here normally trigger DTCs) especially if you had recent work done.

The following diagram may help trace circuits. For the wires that go off the diagram in the pic:
Black/white goes to pin 54 (Fuel pump driver) on the ECU
Green/Black goes to pin 40 (Fuel pump driver) on the ECU
Green/Orange goes to the fuel pump relay pin 5

btw, it's fuse 12 for the fuel pump on the SVT; you probably already knew that.

 

·
Registered
Joined
·
145 Posts
Discussion Starter #11
predator says 0psi frp, I've never used it for data logging so theres alot of information in the fuel section that I don't know what it means.
 

·
Registered
Joined
·
145 Posts
Discussion Starter #13
tried it with predator and indicates 0 fuel pressure, do you think the fuel pump driver module could be bad without a cel?
 

·
DTC P0606
Joined
·
3,364 Posts
Can I ask what circumstances prompted you to replace the fuel pump in the first place? And what replacement parts did you use?
You mentioned something about an ECU replacement?

In these kind of situations, simply because the part - the pump - is new shouldn't eliminate it as a possible problem cause (although it'd be nice if that was always the case).
You can use the wiring diagram to see which wire at the FPDM should be seeing 12V. Trace the wire and see how far along the circuit you are getting power.
Perhaps it's a simple as a wire break or a electrical connector not being fully seated.
 

·
Registered
Joined
·
145 Posts
Discussion Starter #15
Peventative maintenance, the car had 135,000 when I replaced it and I replaced it with a motorcraft fuel pump, A little back story for about 3 months prior the car has run rough when cold started and then would come out of it about 30 secs. and run fine. I had swaped out the ECU relay last sat. and it started right up and ran good until thurs. 27th and did the same thing again, starting briefly and stalled and wouldn't restart.
 

·
Registered
Joined
·
145 Posts
Discussion Starter #17
R8 in the engine compartment, swaped the fog lamp R13 relay with R8 started right up after, but it didn't work this time
 
1 - 18 of 18 Posts
Top