Focus Fanatics Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-13 of 13 Results
  1. MK1 Focus
    Hi , ive had an 03 zx3 for about 2ish months now. When I bought it, it had a misfire. Fixed that and it drove very very well for a long time minus a couple interior quirks. One day it wouldnt start, no noises or anything the car would just go into accessory mode, so i bump started it home. Tried...
  2. MK2 Focus
    Hey, so I have been having some major electrical issues with my focus. Now, the car came without a service history, so before I bought it at the beginning of last summer I have absolutely 0 clue about it's history. So, my electrical problems have been going on for a while and I have been able...
  3. General Technical Chat
    Hello all, I have a 2015 Focus SE with about 70,000 miles on it and about two weeks ago, the front passenger side windshield wiper stopped functioning; the driver side and rear wipers function normally. Since then, I have replaced the wiper fuse, replaced the wiper motor itself, replaced my...
  4. General Technical Chat
    Hello to all. I'm a newbie here so if my question had already been asked, please accept my apology. So yesterday I decided to detail my interior on my 2015 Ford Focus. I started it, switched spots with another car and proceeded to clean, vacuum, and organize it for about 2 hours. Once finished I...
  5. MK3 Focus
    Hello guys, I'm having a really frustrating problem that I can't seem to get to the bottom of. Just to give a bit of background, I will give ALL the information I have and be as thorough as I can be in hopes that someone here can help me. I have a 2012 MK3 Ford Focus SEL Back in July I had...
  6. General Technical Chat
    Hey all, thanks in advance for your help. I have a 2014 Focus SE and while i was changing the battery, I made the rookie mistake of touching the positive terminal with my ratchet while tightening the negative terminal. Long story short, now my traction control light is on after displaying...
  7. General Technical Chat
    I've had a series of issues over the last 8 months across two different cars, the first being a '07 plate Peugeot 207 and the latter being a '62 plate Ford Focus (Titanium). The reason I'm mentioning the Peugeot is because the exact same faults have now occurred on both vehicles. Last Autumn, I...
  8. MK1 Focus
    So I have a Ford Focus first gen, 2005 zx4 to be exact and I have this issue where I put the key in and I turn it and nothing happens. No lights, no crank or start. I recently replaced the battery, alternator and positive and negative cables and still nothing. I was thinking it may be a fuse or...
  9. ZETEC Performance (2000-2004)
    The infamous blowing of fuse 32 led me to check for some wiring issues, I was not happy with what I found. The previous owner has cut a lot of corners and I'm not sure what is going on here. On my 2001 ZX3's lift gate I found a wire spliced and connected to another. These wires being...
  10. MK2 Interior Mods & Upgrades
    Yes...I know the issue of 2008-09 Foci missing rear dome lights from the factory has been addressed already. In fact this thread is inspired largely by DarderSauce’s write-up on how he installed LED stripping along the back window. I liked that idea, but I really like to keep everything looking...
  11. General Technical Chat
    I recently began having a problem with my car's electrical system. The thing that red flagged it to me was that my amp (powering my sub) would only power on with the car off, but when I turn the car on, the amp goes into protect mode. It had been hooked up the way it was for a long time with no...
  12. General Technical Chat
    When i installed my HID's back in 2007 i noticed that my car had a problem but since i left for college and didnt get to drive my car at all [:(] , i didnt take the time to figure it out. Maybe you guys can help. When the HID's are turned on the radio begins to have this really annoying hiss...
  13. General Technical Chat
    I have been having problems with my Focus cutting off while I am driving and everytime it does it, my cd/radio player restarts with no saved stations or anything. It is like my battery is being disconnected and reconnected while drivning...because the thing is my car never completely cuts off...
1-13 of 13 Results
Top