Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (https://www.focusfanatics.com/forum/)
-   MK3 Focus (https://www.focusfanatics.com/forum/mk3-focus/)
-   -   Code P0420, the saga continues... (https://www.focusfanatics.com/forum/mk3-focus/811351-code-p0420-saga-continues.html)

SupraGuy 03-15-2019 03:38 PM

Code P0420, the saga continues...
 
Okay, I've owned this car a month, and it's going to the shop a fourth time now.

After new TCU, clutch and seals, the car started throwing P0420, catalytic converter below threshold efficiency. I don't have a ton of miles on this car, about 75k(120,000 km) which shouldn't be too much, yet. The fact that it closely follows transmission service makes me think something either smacked the O2 sensor, or induced a leak. Naturally, dealership says impossible.

You'd think they would remember how loud I can complain in their showroom.

Suddenly tech checks, and somehow the cat is under warranty. Well, fine, I guess.

I bought this because I didn't want a car that needed fixing on the weekends so that I could get to work during the week. Well, come summer, at least I should have an option....

Djdylan 03-15-2019 05:16 PM

Would also love to know if its actually the cat that's gone bad or just sensors.

I have 191,000KM and CEL just came on with this code.

O2S1 replaced at 160,000 KM



Edit:

Please see recall #18S32

zehkaiser 04-23-2019 11:21 AM

Quote:

Originally Posted by Djdylan (Post 11367807)
Would also love to know if its actually the cat that's gone bad or just sensors.

I have 191,000KM and CEL just came on with this code.

O2S1 replaced at 160,000 KM



Edit:

Please see recall #18S32

Did you replace the sensors? I've had this intermittent CEL since about 102k mi and thought it was related to the recall you mentioned. I wasn't that lucky, and will be replacing my sensors to see if the CEL goes away.

SupraGuy 04-23-2019 11:30 AM

Well the dealership replaced the cat, but not the O2 sensors, and the CEL went away. Of course they also replaced the gasket in the exhaust system, which is also a possible source of the problem.

Most times O2 sensors don't go bad too quickly, unless you're burning something unusual, like oil or sometimes certain cleaners. Also using certain sealants in the intake system can result in fumes which harm O2 sensors (Most RTV is now marked "sensor safe" and does not produce these fumes.) I've also brought back some O2 sensors by heating it with a nice clean flame, like a propane torch and burning off contamination, but usually it's more cost effective to just buy a new sensor, so long as you've fixed the problem that caused it to foul.

Anyway, the dealership said it was the cat which failed because of the purge valve issue, which also got me a new gas tank.

Now I need to get my backup camera working again. This car has been a parade of problems so far...

Djdylan 04-23-2019 11:32 AM

Quote:

Originally Posted by zehkaiser (Post 11375181)
Quote:

Originally Posted by Djdylan (Post 11367807)
Would also love to know if its actually the cat that's gone bad or just sensors.

I have 191,000KM and CEL just came on with this code.

O2S1 replaced at 160,000 KM



Edit:

Please see recall #18S32

Did you replace the sensors? I've had this intermittent CEL since about 102k mi and thought it was related to the recall you mentioned. I wasn't that lucky, and will be replacing my sensors to see if the CEL goes away.




After about 1 000km CEL went away and never came back.

Hopefully Ford comes with a fix for this recall soon though

zehkaiser 04-23-2019 11:32 AM

Dang. I was hoping my dealership would be a bit better. I was just told that the cat wasn't covered in the recall and that I was on my own. Figures.

saintsfins 04-23-2019 11:34 AM

Quote:

Originally Posted by zehkaiser (Post 11375189)
Dang. I was hoping my dealership would be a bit better. I was just told that the cat wasn't covered in the recall and that I was on my own. Figures.

Bummer. Curious, did they give you an estimate?

zehkaiser 04-23-2019 11:37 AM

I didn't. I decided to walk and hope the CEL would go away after the recall repair. I'm trying the O2 sensor on my own to see if that works. I'm not interested in hundreds of dollars for a new cat.

SupraGuy 04-23-2019 01:03 PM

I was told that the warranty on the cat was extended, probably due to the purge valve recall. I have 120,000 km, they checked up to 140,000 for the warranty coverage, so I don't know if 160,000 would still be covered.

stayboogy 04-28-2019 01:44 PM

My P0420 started at 98k miles. TCM had been replaced by Ford at 75k. I replaced the purge valve first and the P0420 kept coming back every 5k-8k miles. I finally replaced the downstream o2 sensor and added an o2 sensor extender and this fixed the problem. My cat isn't clogged or anything and I now have nearly 146k miles on it with no trouble codes and has passed emission testing.

see here: https://www.focusfanatics.com/forum/...20-solved.html


All times are GMT -5. The time now is 04:22 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.