Cruise control and speed limiter - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Third Generation > MK3 Focus

MK3 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the third generation 2012-Current Focus.

Search This Forum | Image Search | Advanced Search    
FocusFest

Reply
 
LinkBack Thread Tools Display Modes
Old 10-07-2018, 04:57 AM   #1
Focus Rookie
 
Join Date: Sep 2012
Fan#: 103559
Location: Dubai, United Arab Emirates
What I Drive: 2012 Blazer Blue Sport

Posts: 7
Points 110, Level 2
Points: 110, Level: 2 Points: 110, Level: 2 Points: 110, Level: 2
Level Up 20% Completed
Level up: 20% Level up: 20% Level up: 20%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 AlexD Good Standing Member
Buy-Sell-Trade Rating: (0)
Cruise control and speed limiter

Hi Guys,

My cruise control stopped working about 6 months back - it was working on and off before but then it stopped to work completely - just doesn't engage.
In this time the speed limiter was working though, but this also stopped working about a week ago. Both are on the same buttons group.

Any idea if this would be just the CC button assembly that has to be replaced or
might be some other complex stuff to be looked at?

The car has 160K km on board.

Thanks.


AlexD is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-23-2018, 12:57 AM   #2
Focus Rookie
 
Join Date: Sep 2012
Fan#: 103559
Location: Dubai, United Arab Emirates
What I Drive: 2012 Blazer Blue Sport

Posts: 7
Points 110, Level 2
Points: 110, Level: 2 Points: 110, Level: 2 Points: 110, Level: 2
Level Up 20% Completed
Level up: 20% Level up: 20% Level up: 20%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 AlexD Good Standing Member
Buy-Sell-Trade Rating: (0)
So I went to a garage to diagnose the issue: They found some PCM error while reading the OBD.
- they checked all the fuses: no problem
- they checked to see if it's the actual button Assembly: no problem, all buttons were creating connection
- no problem with the brake lights

It turns out to be 2 connectors that come from the power steering and go inside this PCM that is located somewhere down behind the engine, a bit on the passenger side. So remove the engine cover and roll up sleeves, and down there first is a metallic cover to protect probably this PCM connections, remove that and bum you will see the connectors.
They disconnected these 2 connectors, cleaned them really well and back in. The CC and speed limiter work perfectly now.

They explained that with time the connectors get in touch with moist, maybe water, dirt etc.
That is why when the CC issue started to appear it was working on and off, till got to not work at all, so the connectors had maybe moist on and off.

Hope this helps. Cheers.
AlexD is offline  
    Reply With Quote Quick reply to this message
Old 07-17-2019, 10:54 AM   #3
Focus Rookie
 
Join Date: Sep 2014
Fan#: 191465
Location: casablanca, Morocco
What I Drive: 2011 Mars Red TDCI (115cv Moroccan)

Posts: 9
Points 42, Level 1
Points: 42, Level: 1 Points: 42, Level: 1 Points: 42, Level: 1
Level Up 84% Completed
Level up: 84% Level up: 84% Level up: 84%
Forum Activity 5%
Activity: 5% Activity: 5% Activity: 5%
FF Reputation: 1 ismail Good Standing Member
Buy-Sell-Trade Rating: (0)
hello dear can you please show me where are the connectors please?
ismail is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-17-2019, 11:41 AM   #4
Focus Rookie
 
Join Date: Sep 2014
Fan#: 191465
Location: casablanca, Morocco
What I Drive: 2011 Mars Red TDCI (115cv Moroccan)

Posts: 9
Points 42, Level 1
Points: 42, Level: 1 Points: 42, Level: 1 Points: 42, Level: 1
Level Up 84% Completed
Level up: 84% Level up: 84% Level up: 84%
Forum Activity 5%
Activity: 5% Activity: 5% Activity: 5%
FF Reputation: 1 ismail Good Standing Member
Buy-Sell-Trade Rating: (0)
is it possible to get a picture please? dismantled everything couldn't point it
ismail is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Focus Centennial Edition Sedan
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:25 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum and Volvo XC90 Forum.




 

Search Engine Optimization by vBSEO 3.6.1