Navigation Fault, Dealer Won't Help - Page 4 - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Third Generation > MK3 Focus

MK3 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the third generation 2012-Current Focus.

Search This Forum | Image Search | Advanced Search    
FocusFest

Reply




 
LinkBack Thread Tools Display Modes
Old 01-10-2012, 04:26 AM   #31
Focus Jr. Enthusiast
 
Join Date: Dec 2011
Fan#: 93258
Location: Clifton, NJ
What I Drive: 2012 Candy Red 5 door Titanium

Posts: 27
FF Reputation: 1 CliftonBruce Good Standing Member
Buy-Sell-Trade Rating: (0)
GREAT! The GPS sensor wasn't in on Monday as the dealer said.. NOW...because it's not a FORD part (wtf) it will take from 7 to 10 working days to get the part from whoever builds it..Just ticks me off.. FIRST of all.. IF it's in a factory built FORD then it;s a FORD PART! SECOND.. STOCK THE CRAP THAT GOES BAD.. I'm sure not the ONLY one with Nav problems..This goes straight to the merchantability of this car! You may be getting a TON of these cars back under the Lemon Laws if you don't get your act together FORD! This is totally sad..
CliftonBruce is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-10-2012, 08:14 AM   #32
Focus Addict
 
csvt2060's Avatar
 
Join Date: Mar 2011
Fan#: 84122
Location: Northwest Indiana, IN
What I Drive: 2013 Ford Escape Titanium

Posts: 772
FF Reputation: 2 csvt2060 Good Standing Member
Buy-Sell-Trade Rating: (0)
Clifton, I share in your frustration and hope you can get your issue resolved soon.

I am ashamed of Ford how they are handling the issues and parts replacements on these cars.
csvt2060 is offline  
    Reply With Quote Quick reply to this message
Old 01-10-2012, 10:03 AM   #33
Focus Addict
 
TiPilot's Avatar
 
Join Date: Jan 2012
Fan#: 93667
Location: Dayton, OH
What I Drive: 2012 Ingot Silver Ti Hatch

Posts: 647
FF Reputation: 1 TiPilot Good Standing Member
Buy-Sell-Trade Rating: (0)
Not to hijack the thread, but I got my first Nav SD fault last night. I've had the car for a week, btw.

Wasn't using Nav, was on the Home screen in MFT and used Sync to switch to my USB (iPod) and the fault/error popped up on screen. MFT couldn't access the iPod for some reason, it hung up for about 10 seconds, then switched back to the radio and another message popped up saying Nav was ready for use. Odd...
__________________
2012 Focus Ti Hatch | Ingot Silver | 401A, Nav, Winter Pkg, Moon Roof, Parking Tech. Pkg

Build Date: 12/2/2011 | New APIM: 4/4/2012
MFT: Factory v2.11, 3/14/12 Web -> v3.0.2, 9/24/12 Web -> v3.2.2, 1/24/13 Web -> v3.5.1, 8/13/13 Web -> v3.6
TiPilot is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-12-2012, 04:01 PM   #34
Focus Enthusiast
 
Join Date: Aug 2011
Fan#: 88463
Location: Haileybury, Canada
What I Drive: 2012 Lincoln MKZ AWD Ingot Silver

Posts: 179
FF Reputation: 2 Blizzard35 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by VOLDAR View Post
I think you are being fed a bunch of BS. Yes, some of us have an issue due to the Navigation SD card, but NONE of us had a problem like yours: GPS not available ! Your problem is not one that can be solved with a software update. So, IMO, go and ask them to take care of your unit, because the "update" has nothing to do with your GPS not being able to see the satelite.
I have had the "GPS not available" on many occasionsin my car. The accuracy of the Nav system is a joke. I even had a Ford of Canada Rep with me in the car, I had him punch in a destination...it took us 4 blocks past the i destination that he entered. Then, while we were returning to the dealership, the "No GPS" indicator, with the red diagonal slash through it appeared on the screen followed by the "SD CARD FAULT" warning.

I was so lucky that I had documented proof that the Navigation system was crap.....hasn't worked right from the day I picked it up in June of 2011 and the guy from Ford of Canada was right beside me and say it with his own two eyes...he made a report...followed up with an email to me and my dealer saying that it would be taken care of, for free with the MyFordTouch update.
Blizzard35 is offline  
    Reply With Quote Quick reply to this message
Old 01-15-2012, 05:32 AM   #35
Focus Jr. Enthusiast
 
Join Date: Dec 2011
Fan#: 93258
Location: Clifton, NJ
What I Drive: 2012 Candy Red 5 door Titanium

Posts: 27
FF Reputation: 1 CliftonBruce Good Standing Member
Buy-Sell-Trade Rating: (0)
OK THIS past Friday they replaced the GPS sensor and everything works fine.. I have a Nav system that works..a clock that now keeps time...and I'm no longer driving WEST all the time LOL.. Things work as they should.. Just hoping it stays that way.
I have to thank the service crew at Quality Ford in Rutherford NJ. They really are good at what they do and care about the customers.. NICE to see at any dealership..
You can buy anywhere but the service after is TOTALLY important!
CliftonBruce is offline  
    Reply With Quote Quick reply to this message
Old 01-15-2012, 08:17 AM   #36
Focus Enthusiast
 
Lincoln61's Avatar
 
Join Date: Oct 2011
Fan#: 90659
Location: Matamoras, PA
What I Drive: 2016 Focus ST

Posts: 155
Points 3,665, Level 38
Points: 3,665, Level: 38 Points: 3,665, Level: 38 Points: 3,665, Level: 38
Level Up 10% Completed
Level up: 10% Level up: 10% Level up: 10%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 Lincoln61 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by csvt2060 View Post
This is all great and stuff........

However, it shouldn't of happened in the first place. It should of never been released in with the issues it had. And Ford has lost customers and credibility over the whole thing. Yes, they can move forward and come up with the "fix all upgrade" but customers and dealers have been dealing with this for almost 2 years. The damage has been done. Let's hope this upgrade is as good as they say it is. I would like a clock that works right among a list of other things.
I have been watching this post for a while now. First off, Ford is head and shoulders above the competition with Sync, does it have some issues? Yes it does, But if your a Hyundai customer you cant use ur bluetooth with ur Iphone. Would you get rid of ur car because of that? Does it change the way the car runs or handles? I think not. The dealer I work at has not lost one customer because of a sync issues. We work with our customer to get it working right.

The NAV problem has seen a couple of antenna issues. If you know how to check your software version and its not at the latest version go to sync my ride to look for updates. If there is none and your having problems you can dump your battery and reboot the system with some good results. Just remove the pos connection for 10 min and connect back up. Wait for about 20 min and try to re-set everything back up.

I have been checking the Oasis website daily for the new update. As soon as I see something I will be happy to share it with you guys and girls.
Lincoln61 is offline  
    Reply With Quote Quick reply to this message
Old 01-15-2012, 10:38 AM   #37
Focus Enthusiast
 
6769MOPARS's Avatar
 
Join Date: May 2011
Fan#: 86108
Location: Powder Springs, GA
What I Drive: PB Focus ST2 and 67 426 Hemi GTX

Posts: 431
Points 571, Level 11
Points: 571, Level: 11 Points: 571, Level: 11 Points: 571, Level: 11
Level Up 43% Completed
Level up: 43% Level up: 43% Level up: 43%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 6769MOPARS Good Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by Lincoln61 View Post
I have been watching this post for a while now. First off, Ford is head and shoulders above the competition with Sync, does it have some issues? Yes it does, But if your a Hyundai customer you cant use ur bluetooth with ur Iphone. Would you get rid of ur car because of that? Does it change the way the car runs or handles? I think not. The dealer I work at has not lost one customer because of a sync issues. We work with our customer to get it working right.

The NAV problem has seen a couple of antenna issues. If you know how to check your software version and its not at the latest version go to sync my ride to look for updates. If there is none and your having problems you can dump your battery and reboot the system with some good results. Just remove the pos connection for 10 min and connect back up. Wait for about 20 min and try to re-set everything back up.

I have been checking the Oasis website daily for the new update. As soon as I see something I will be happy to share it with you guys and girls.
I have Sync in my 11 Fiesta and have no issues. My wife is waiting patiently for the MFT/NAV updates for her 12 Focus Ti but is loving sync so far.
6769MOPARS is offline  
    Reply With Quote Quick reply to this message
Old 01-15-2012, 11:07 AM   #38
Focus Enthusiast
 
Lincoln61's Avatar
 
Join Date: Oct 2011
Fan#: 90659
Location: Matamoras, PA
What I Drive: 2016 Focus ST

Posts: 155
Points 3,665, Level 38
Points: 3,665, Level: 38 Points: 3,665, Level: 38 Points: 3,665, Level: 38
Level Up 10% Completed
Level up: 10% Level up: 10% Level up: 10%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 Lincoln61 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by 6769MOPARS View Post
I have Sync in my 11 Fiesta and have no issues. My wife is waiting patiently for the MFT/NAV updates for her 12 Focus Ti but is loving sync so far.
I have had 2 small issues with mine that did not require a tech to repair it. I do not have the MFT screen I am in a SE sport with 203a. Both times were with my ipod only playing one song and stuck on that song. The first time the advanced menu reset fixed the issue the second time, I had to dump the battery for 10 min.

It is frustrating when something does not work right. The MFT issues will be resolved. And Im sure the update will be worth the wait..
Lincoln61 is offline  
    Reply With Quote Quick reply to this message
Old 09-20-2015, 10:33 PM   #39
Focus Rookie
 
Join Date: Sep 2015
Fan#: 265137
Location: Union, NJ
What I Drive: 2012,Sterling Gray, focus titanium

Posts: 1
Points 4, Level 1
Points: 4, Level: 1 Points: 4, Level: 1 Points: 4, Level: 1
Level Up 7% Completed
Level up: 7% Level up: 7% Level up: 7%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 jay33 Good Standing Member
Buy-Sell-Trade Rating: (0)
I had the same problem with the Navigation fault. It also affected the bluetooth.
I was going to take it to the dealer until I came across this forum and read the suggestion
about pulling fuses 67 and 79. So I tried that and it now works fine. Thanks for the
info.
jay33 is offline  
    Reply With Quote Quick reply to this message
Old Yesterday, 08:58 PM   #40
Focus Rookie
 
Join Date: Jan 2019
Fan#: 408521
Location: Peterborough, Canada
What I Drive: 2016 Titanium 5-Dr Shadow Black

Posts: 3
Points 6, Level 1
Points: 6, Level: 1 Points: 6, Level: 1 Points: 6, Level: 1
Level Up 11% Completed
Level up: 11% Level up: 11% Level up: 11%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 1 riproaringca Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by CliftonBruce View Post
Mine drives me nuts and the car isn't a week old. The Nav pulled the fault day TWO of ownership.. PLUS my clock won't hold time .. the outside temp reading is WAY off by a good 25 degrees and... I'm always driving west for the compass :) They told me all of those things are the result of the bad nav... I'll know more Friday 1/6/2012 when I bring it in to service this,.. We'll see..
My temp was WAY off due to a corroded contact in the passenger side mirror's thermometer/temp sensor, which was shorting out. Dealership cleaned that up for me and there hasn't been a problem like it since. (The alternative is replacing the whole mirror assembly, which is definitely NOT in the budget!)
riproaringca is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Focus Centennial Edition Sedan
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:00 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum and Volvo XC90 Forum.




 

Search Engine Optimization by vBSEO 3.6.1