05 ZX4 Oil Pressure light not coming on when engine is off - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus First Generation > MK1 Focus

MK1 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the first generation 2000-2007 Focus.

Search This Forum | Image Search | Advanced Search    
FocusFest

Like Tree4Likes
  • 2 Post By amc49
  • 1 Post By nephron
  • 1 Post By nephron
Reply
 
LinkBack Thread Tools Display Modes
Old 11-17-2018, 01:41 PM   #1
Focus Enthusiast
 
SparkE's Avatar
 
Join Date: May 2013
Fan#: 114762
Location: Some City, FL
What I Drive: 2005 Gold Focus ZX4 S

Posts: 153
Points 3,369, Level 36
Points: 3,369, Level: 36 Points: 3,369, Level: 36 Points: 3,369, Level: 36
Level Up 13% Completed
Level up: 13% Level up: 13% Level up: 13%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 SparkE Good Standing Member
Buy-Sell-Trade Rating: (0)
05 ZX4 Oil Pressure light not coming on when engine is off

So I noticed something strange, when I turn the key forward certain lights are supposed to be lit and the Oil pressure light is supposed to be one of them but it isn't. Sometimes, when starting the car it does light up like it's supposed to other times it's just not there.

I'm not sure if the problem is in my gauge cluster or if the oil sender is bad..
I'm looking into replacing the gauge cluster because I want a tach since this one doesn't have one. Unfortunately before I can replace the gauge cluster I have to pay off this car in full. It was financed from a used car dealer and I have 8 payments left.


SparkE is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-17-2018, 06:21 PM   #2
Focus Fanatic
 
Join Date: Mar 2012
Fan#: 96610
Location: Fort Worth, TX
What I Drive: 00 wagon, 02 sedan both zetec atx

Posts: 15,376
Points 9,503, Level 65
Points: 9,503, Level: 65 Points: 9,503, Level: 65 Points: 9,503, Level: 65
Level Up 51% Completed
Level up: 51% Level up: 51% Level up: 51%
Forum Activity 100%
Activity: 100% Activity: 100% Activity: 100%
FF Reputation: 62 amc49 Excellent Standing Member
Buy-Sell-Trade Rating: (0)
Likely sending unit if erratic, bulb would stay off once blown. In most cases anyway, the bulb filament could always freakily drop to swing and touch to work then not, like a Trumpian lie.
felixthecat and SparkE like this.
__________________
Fix the driver first, then fixing the car becomes so much easier..........
amc49 is offline  
    Reply With Quote Quick reply to this message
Old 11-18-2018, 12:57 PM   #3
Focus Enthusiast
 
nephron's Avatar
 
Join Date: Oct 2018
Fan#: 406377
Location: lake elsinore, CA
What I Drive: 04 Focus ZTS Sport, 02 Mustang GT

Posts: 148
Points 343, Level 6
Points: 343, Level: 6 Points: 343, Level: 6 Points: 343, Level: 6
Level Up 86% Completed
Level up: 86% Level up: 86% Level up: 86%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 1 nephron Good Standing Member
Buy-Sell-Trade Rating: (0)
Should work on yours.Try this:
SparkE likes this.
nephron is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-18-2018, 07:57 PM   #4
Focus Enthusiast
 
SparkE's Avatar
 
Join Date: May 2013
Fan#: 114762
Location: Some City, FL
What I Drive: 2005 Gold Focus ZX4 S

Posts: 153
Points 3,369, Level 36
Points: 3,369, Level: 36 Points: 3,369, Level: 36 Points: 3,369, Level: 36
Level Up 13% Completed
Level up: 13% Level up: 13% Level up: 13%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 SparkE Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by nephron View Post
Should work on yours.Try this:https://www.youtube.com/watch?v=X6h-0M1lHFQ

I actually tried this today, took a little bit of firm pressing on the button but I noticed the light doesn't come on during the LED test either... Which I think means it's somehow blown. Meaning I will have to get a new gauge cluster which is fine, I can get it from a junker focus at my local Junk yard because these LED's aren't replaceable I think.

Now if the new cluster doesn't show the oil light either then I've got a problem... a solvable problem but none the less... a problem.
SparkE is offline  
    Reply With Quote Quick reply to this message
Old 11-18-2018, 11:27 PM   #5
Focus Enthusiast
 
nephron's Avatar
 
Join Date: Oct 2018
Fan#: 406377
Location: lake elsinore, CA
What I Drive: 04 Focus ZTS Sport, 02 Mustang GT

Posts: 148
Points 343, Level 6
Points: 343, Level: 6 Points: 343, Level: 6 Points: 343, Level: 6
Level Up 86% Completed
Level up: 86% Level up: 86% Level up: 86%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 1 nephron Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by SparkE View Post
I actually tried this today, took a little bit of firm pressing on the button but I noticed the light doesn't come on during the LED test either... Which I think means it's somehow blown. Meaning I will have to get a new gauge cluster which is fine, I can get it from a junker focus at my local Junk yard because these LED's aren't replaceable I think.

Now if the new cluster doesn't show the oil light either then I've got a problem... a solvable problem but none the less... a problem.
I believe it is a bulb.....I found this:The 2005-2007 Focus clusters use the 2721 bulbs, 3 for non-tach clusters and 5 in tach clusters. You Tube has some videos on it too.
SparkE likes this.
nephron is offline  
    Reply With Quote Quick reply to this message
Old 11-19-2018, 08:14 PM   #6
Focus Fanatic
 
Join Date: Mar 2012
Fan#: 96610
Location: Fort Worth, TX
What I Drive: 00 wagon, 02 sedan both zetec atx

Posts: 15,376
Points 9,503, Level 65
Points: 9,503, Level: 65 Points: 9,503, Level: 65 Points: 9,503, Level: 65
Level Up 51% Completed
Level up: 51% Level up: 51% Level up: 51%
Forum Activity 100%
Activity: 100% Activity: 100% Activity: 100%
FF Reputation: 62 amc49 Excellent Standing Member
Buy-Sell-Trade Rating: (0)
Yes, some replaceable bulb along with LED........
__________________
Fix the driver first, then fixing the car becomes so much easier..........
amc49 is offline  
    Reply With Quote Quick reply to this message
Old 12-04-2018, 08:23 PM   #7
Focus Addict
 
Paul1958's Avatar
 
Join Date: Apr 2014
Fan#: 157234
Location: Hudson, MA
What I Drive: 2002 Focus wagon 2.0L Zetec 5-speed

Posts: 911
Points 5,532, Level 47
Points: 5,532, Level: 47 Points: 5,532, Level: 47 Points: 5,532, Level: 47
Level Up 91% Completed
Level up: 91% Level up: 91% Level up: 91%
Forum Activity 100%
Activity: 100% Activity: 100% Activity: 100%
FF Reputation: 17 Paul1958 Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by nephron View Post
I believe it is a bulb.....I found this:The 2005-2007 Focus clusters use the 2721 bulbs, 3 for non-tach clusters and 5 in tach clusters. You Tube has some videos on it too.
I believe that on the 05-07 clusters (and perhaps some 03-04 as well) only the cluster illumination lamps are replaceable bulbs/sockets (that is the 3/5 you are talking about). All the warning lamp bulbs are hard soldered in. I believe this was done to prevent easy tampering (ie pulling out an illuminated CEL lamp, etc).

Paul
__________________
2005 ZX4 SE 2.0L Duratec 5-speed 191K miles
2002 Wagon SE 2.0L Zetec 5-speed 135K miles
Paul1958 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Focus Centennial Edition Sedan
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:12 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum and Volvo XC90 Forum.




 

Search Engine Optimization by vBSEO 3.6.1