strong gas smell at rear of car - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest

Like Tree1Likes
Reply




 
LinkBack Thread Tools Display Modes
Old 09-04-2019, 02:12 PM   #1
Focus Rookie
 
Allcruisen's Avatar
 
Join Date: Sep 2019
Fan#: 415669
Location: Dallas, TX
What I Drive: 2002 ZX5

Posts: 17
Points 42, Level 1
Points: 42, Level: 1 Points: 42, Level: 1 Points: 42, Level: 1
Level Up 84% Completed
Level up: 84% Level up: 84% Level up: 84%
Forum Activity 51%
Activity: 51% Activity: 51% Activity: 51%
FF Reputation: 1 Allcruisen Good Standing Member
Buy-Sell-Trade Rating: (0)
strong gas smell at rear of car

As the thread states. I have been having a really strong gas smell at the rear of the wife's 2002 ZX-5. I already dropped the tank and didn't find any leaks. I also replaced the Smog canister, the return hose that goes over the tank and the 5/8" fuel hose that goes to the check valve mounted at the top of the body by gas tank.

When filling the tank, I never go pass the auto shut off {old habit}, I started off with the simple replacement such as the gas cap.

Just saw a write up that my problem could also be the Emission Check Valve Located in the Engine Bay. Is there any way to check this part?

Wife just told me that the smell is now on the inside of the vehicle also.

Any help would be greatly appreciated as I am stuck on to what is causing this issue.

PS NO CEL, No stored Codes either

Thanks in advance,

Allcruisen


__________________
"DEATH BEFORE DISHONOR"

Our Stable:
'95 Bronco, '02 Focus ZX-5
Allcruisen is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-04-2019, 09:19 PM   #2
Focus Addict
 
Paul1958's Avatar
 
Join Date: Apr 2014
Fan#: 157234
Location: Hudson, MA
What I Drive: 2002 Focus wagon 2.0L Zetec 5-speed

Posts: 803
Points 4,919, Level 44
Points: 4,919, Level: 44 Points: 4,919, Level: 44 Points: 4,919, Level: 44
Level Up 85% Completed
Level up: 85% Level up: 85% Level up: 85%
Forum Activity 63%
Activity: 63% Activity: 63% Activity: 63%
FF Reputation: 16 Paul1958 Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Allcruisen View Post
As the thread states. I have been having a really strong gas smell at the rear of the wife's 2002 ZX-5. I already dropped the tank and didn't find any leaks. I also replaced the Smog canister, the return hose that goes over the tank and the 5/8" fuel hose that goes to the check valve mounted at the top of the body by gas tank.

When filling the tank, I never go pass the auto shut off {old habit}, I started off with the simple replacement such as the gas cap.

Just saw a write up that my problem could also be the Emission Check Valve Located in the Engine Bay. Is there any way to check this part?

Wife just told me that the smell is now on the inside of the vehicle also.

Any help would be greatly appreciated as I am stuck on to what is causing this issue.

PS NO CEL, No stored Codes either

Thanks in advance,

Allcruisen
By 'smog canister' do you mean EVAP Canister (fuel vapor storage)?
By 'check valve' do you mean the Canister Vent Solenoid mounted on the canister?
Have you inspected the fuel filler pipe for thru corrosion?
Does the EVAP Monitor (drive cycle) show complete on scan tool?
Was there any fuel odor reduction (even temporarily) after replacing the canister?
Is the fuel odor worse during or just after refueling?

Are you the 'Bronco' Allcruisen?

Paul
__________________
2005 ZX4 SE 2.0L Duratec 5-speed 191K miles
2002 Wagon SE 2.0L Zetec 5-speed 135K miles
Paul1958 is offline  
    Reply With Quote Quick reply to this message
Old 09-04-2019, 11:00 PM   #3
Focus Rookie
 
Allcruisen's Avatar
 
Join Date: Sep 2019
Fan#: 415669
Location: Dallas, TX
What I Drive: 2002 ZX5

Posts: 17
Points 42, Level 1
Points: 42, Level: 1 Points: 42, Level: 1 Points: 42, Level: 1
Level Up 84% Completed
Level up: 84% Level up: 84% Level up: 84%
Forum Activity 51%
Activity: 51% Activity: 51% Activity: 51%
FF Reputation: 1 Allcruisen Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Paul1958 View Post
By 'smog canister' do you mean EVAP Canister (fuel vapor storage)?
By 'check valve' do you mean the Canister Vent Solenoid mounted on the canister?
Have you inspected the fuel filler pipe for thru corrosion?
Does the EVAP Monitor (drive cycle) show complete on scan tool?
Was there any fuel odor reduction (even temporarily) after replacing the canister?
Is the fuel odor worse during or just after refueling?

Are you the 'Bronco' Allcruisen?

Paul
Paul, Yes I am allcruisen on FSB .

1 ? - Yes EVAP Canister
2 ? - No There is one up top that has two hoses going into it, round in shape held up by a bracket with two nuts. I know it has a 5/8" hose going to it that I replaced and an flex type hose {same size} going to a T that goes to the Canister Vent Solenoid mounted on the canister
3 ? - Yes and there is no rust or any corrosion, also replaced the rubber filler hose
4 ? - Not sure what you mean or how to check for {drive cycle}
5 ? - I really didn't notice much change at all.
6 ? - Not really, Actually when I filled it up after replacing the EVAP Canister and hoses it didn't smell as much as when I park the car in the garage after a drive

I appreciate any and all suggestions as to what is causing this issue.

PS Thinking of making a DIY smoke machine this weekend to see if I missed something.

Thanks,
Allcruisen
__________________
"DEATH BEFORE DISHONOR"

Our Stable:
'95 Bronco, '02 Focus ZX-5
Allcruisen is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-04-2019, 11:25 PM   #4
Focus Addict
 
Paul1958's Avatar
 
Join Date: Apr 2014
Fan#: 157234
Location: Hudson, MA
What I Drive: 2002 Focus wagon 2.0L Zetec 5-speed

Posts: 803
Points 4,919, Level 44
Points: 4,919, Level: 44 Points: 4,919, Level: 44 Points: 4,919, Level: 44
Level Up 85% Completed
Level up: 85% Level up: 85% Level up: 85%
Forum Activity 63%
Activity: 63% Activity: 63% Activity: 63%
FF Reputation: 16 Paul1958 Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Allcruisen View Post
4 ? - Not sure what you mean or how to check for {drive cycle}

PS Thinking of making a DIY smoke machine this weekend to see if I missed something.

Thanks,
Allcruisen
All OBDII vehicles have self test monitors that usually run with each drive cycle. OBDII scan tool should tell what monitors have run and are complete. You need to check your EVAP monitor.

Either a EVAP system leak or perhaps the system is not purging correctly and EVAP Canister is saturated. Have you checked Canister Purge Solenoid (in engine compartment) for operation and vapor integrity to the EVAP Canister? Smoke test may be needed.

Paul
__________________
2005 ZX4 SE 2.0L Duratec 5-speed 191K miles
2002 Wagon SE 2.0L Zetec 5-speed 135K miles
Paul1958 is offline  
    Reply With Quote Quick reply to this message
Old 09-05-2019, 02:41 AM   #5
Focus Rookie
 
Allcruisen's Avatar
 
Join Date: Sep 2019
Fan#: 415669
Location: Dallas, TX
What I Drive: 2002 ZX5

Posts: 17
Points 42, Level 1
Points: 42, Level: 1 Points: 42, Level: 1 Points: 42, Level: 1
Level Up 84% Completed
Level up: 84% Level up: 84% Level up: 84%
Forum Activity 51%
Activity: 51% Activity: 51% Activity: 51%
FF Reputation: 1 Allcruisen Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Paul1958 View Post
All OBDII vehicles have self test monitors that usually run with each drive cycle. OBDII scan tool should tell what monitors have run and are complete. You need to check your EVAP monitor.

Either a EVAP system leak or perhaps the system is not purging correctly and EVAP Canister is saturated. Have you checked Canister Purge Solenoid (in engine compartment) for operation and vapor integrity to the EVAP Canister? Smoke test may be needed.

Paul
Paul I can't thank you enough for helping me get to the bottom of this problem. No, I haven't check the one in the engine compartment. Can you explain how to check that one out ? I did notice it is a part no longer available. I just found one on amazon.

Also, the EVAP Canister was not saturated at all. I blew air from my shop air compressor {at about 10 PSI} through one opening and it just blew out a small puff of black smoke. I'm presuming that was just some carbon, I did replace it with a new one though.

Again your help is greatly appreciated as I am stump on this.

Allcruisen
__________________
"DEATH BEFORE DISHONOR"

Our Stable:
'95 Bronco, '02 Focus ZX-5

Last edited by Allcruisen; 09-05-2019 at 10:05 AM. Reason: found a part on amazon
Allcruisen is offline  
    Reply With Quote Quick reply to this message
Old 09-05-2019, 11:42 AM   #6
Focus Addict
 
Paul1958's Avatar
 
Join Date: Apr 2014
Fan#: 157234
Location: Hudson, MA
What I Drive: 2002 Focus wagon 2.0L Zetec 5-speed

Posts: 803
Points 4,919, Level 44
Points: 4,919, Level: 44 Points: 4,919, Level: 44 Points: 4,919, Level: 44
Level Up 85% Completed
Level up: 85% Level up: 85% Level up: 85%
Forum Activity 63%
Activity: 63% Activity: 63% Activity: 63%
FF Reputation: 16 Paul1958 Great Standing Member
Buy-Sell-Trade Rating: (0)
Im not sure I can help as these systems can be difficult to diagnose. The intersting thing here is that your car has given no indication that the system has failed but you have a strong odor of gas which would indicate a leak somewhere. The manufacturers (ie Ford) hold the operation of these systems close to the vest and understanding their operation is the key to being able to diagnose. The Canister Purge solenoid is signaled by the PCM to open (it is normally closed) under certain conditions to 'purge' the canister of accumulated vapors. The PCM also signals the normally open Vent Solenoid (at the Canister) to close to run its self test leak check during/after a drive cycle (tank pressure sensor looks for vacuum). The Purge Solenoid is in the engine compatment near the firewall on the passengers side and is connected between the engine intake manifold and Canister. Im showing Ford YS4Z9C915BA, Motorcraft CX2397 or aftermarket equivalent - all still available. Before spending $$ on more parts I would try to verify if the solenoid works (opens) and if the EVAP monitor shows complete on a scan tool. The Purge solenoid is a 12V normally closed solenoid and is connected to vehicle power any time the ignition switch is ON (Power Hold relay ON). The PCM grounds the other side of the solenoid to activate (open) it. You should also verify it is connected to an intake manifold vacuum source. Based on what you have told me I suspect you have a leak as opposed to a satutrated canister and the system will need to be 'smoked', etc.

Here is some good Alldatadiy info on the components and basic operation of the system. It says 2001 Escort but it also covers Focus:
http://www.alldatadiy.com/alldatadiy...2939/124152992

Good luck
Paul
__________________
2005 ZX4 SE 2.0L Duratec 5-speed 191K miles
2002 Wagon SE 2.0L Zetec 5-speed 135K miles
Paul1958 is offline  
    Reply With Quote Quick reply to this message
Old 09-05-2019, 12:19 PM   #7
Focus Rookie
 
Allcruisen's Avatar
 
Join Date: Sep 2019
Fan#: 415669
Location: Dallas, TX
What I Drive: 2002 ZX5

Posts: 17
Points 42, Level 1
Points: 42, Level: 1 Points: 42, Level: 1 Points: 42, Level: 1
Level Up 84% Completed
Level up: 84% Level up: 84% Level up: 84%
Forum Activity 51%
Activity: 51% Activity: 51% Activity: 51%
FF Reputation: 1 Allcruisen Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Paul1958 View Post
Im not sure I can help as these systems can be difficult to diagnose.

Good luck
Paul
Paul, in just one day you have helped me more then anyone else on another site. I really appreciate you help.

This weekend I'm gonna dig into it further. You have pointed me towards some directions that I would not of suspected, ie: I have been concentrated at the rear of the vehicle since that is where the smell is mostly.

I'm gonna make that smoke machine this weekend and see what I find.

Also, As you mentioned, what has me the most confused is that I am not getting any CEL

I'll keep you up to date as to watt I find and hopefully be able to help others with same problem.

Again, Thanks,
Allcruisen
__________________
"DEATH BEFORE DISHONOR"

Our Stable:
'95 Bronco, '02 Focus ZX-5
Allcruisen is offline  
    Reply With Quote Quick reply to this message
Old 09-08-2019, 08:55 AM   #8
Focus Rookie
 
Allcruisen's Avatar
 
Join Date: Sep 2019
Fan#: 415669
Location: Dallas, TX
What I Drive: 2002 ZX5

Posts: 17
Points 42, Level 1
Points: 42, Level: 1 Points: 42, Level: 1 Points: 42, Level: 1
Level Up 84% Completed
Level up: 84% Level up: 84% Level up: 84%
Forum Activity 51%
Activity: 51% Activity: 51% Activity: 51%
FF Reputation: 1 Allcruisen Good Standing Member
Buy-Sell-Trade Rating: (0)
Lightbulb

UPDATE: Yesterday I made a DIY Smoke machine and this is watt I found.

Found smoke coming out from the Purge Valve in the middle where the plastic and the metal connects. Although I am not getting a CEL or stored codes, I am only assuming this has to be my problem.


Also alot of smoke was coming out of this Vent, This I am assuming is normal since it was just venting


This is where I connected the hose from the Smoke machine. It's the return line for the fuel vapors to go back to the canister.


And Finally my Home made smoke machine, Worked excellent.


Thanks,
Allcruisen
__________________
"DEATH BEFORE DISHONOR"

Our Stable:
'95 Bronco, '02 Focus ZX-5
Allcruisen is offline  
    Reply With Quote Quick reply to this message
Old 09-08-2019, 03:00 PM   #9
Focus Addict
 
Join Date: Nov 2011
Fan#: 91663
Location: Houston, TX
What I Drive: 2006 ZX3 SES

Posts: 657
Points 918, Level 16
Points: 918, Level: 16 Points: 918, Level: 16 Points: 918, Level: 16
Level Up 18% Completed
Level up: 18% Level up: 18% Level up: 18%
Forum Activity 99%
Activity: 99% Activity: 99% Activity: 99%
FF Reputation: 6 pbfoot Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Allcruisen View Post
UPDATE: Yesterday I made a DIY Smoke machine and this is watt I found.

Found smoke coming out from the Purge Valve in the middle where the plastic and the metal connects. Although I am not getting a CEL or stored codes, I am only assuming this has to be my problem.


Also alot of smoke was coming out of this Vent, This I am assuming is normal since it was just venting [IMG class=inlineimg]https://www.focusfanatics.com/forum/images/smilies/icon_smile_headscratch.gif[/IMG]


This is where I connected the hose from the Smoke machine. It's the return line for the fuel vapors to go back to the canister.


And Finally my Home made smoke machine, Worked excellent.


Thanks,
Allcruisen
Good job. Looks like you found it. Nice Magyvering.
pbfoot is offline  
    Reply With Quote Quick reply to this message
Old 09-08-2019, 04:40 PM   #10
Focus Rookie
 
Allcruisen's Avatar
 
Join Date: Sep 2019
Fan#: 415669
Location: Dallas, TX
What I Drive: 2002 ZX5

Posts: 17
Points 42, Level 1
Points: 42, Level: 1 Points: 42, Level: 1 Points: 42, Level: 1
Level Up 84% Completed
Level up: 84% Level up: 84% Level up: 84%
Forum Activity 51%
Activity: 51% Activity: 51% Activity: 51%
FF Reputation: 1 Allcruisen Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by pbfoot View Post
Good job. Looks like you found it. Nice Magyvering.
Thanks, watt still has me puzzled is that no CEL and no storage codes for a bad Purge Valve Solenoid or anything else for that matter, but then again when both the ZX-3 {Son's car} and the ZX-5 cats were clogged no CEL either, but yet if we don't tighten the gas cap all the way, sure enough a CEL comes on

Ordered the Valve and should have it in this week.

PS The smoke machine was credited to you tube videos.

Thanks,
Allcruisen
__________________
"DEATH BEFORE DISHONOR"

Our Stable:
'95 Bronco, '02 Focus ZX-5
Allcruisen is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Focus Centennial Edition Sedan
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:38 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum and Volvo XC90 Forum.




 

Search Engine Optimization by vBSEO 3.6.1