Manual Shifting Problems - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest

Reply
 
LinkBack Thread Tools Display Modes
Old 07-26-2019, 02:27 PM   #1
Focus Enthusiast
 
Join Date: Apr 2005
Fan#: 21303
Location: St. Louis, MO
What I Drive: 2007 ST & 97 Cobra

Posts: 70
Points 705, Level 14
Points: 705, Level: 14 Points: 705, Level: 14 Points: 705, Level: 14
Level Up 5% Completed
Level up: 5% Level up: 5% Level up: 5%
Forum Activity 5%
Activity: 5% Activity: 5% Activity: 5%
FF Reputation: 1 shoeman Good Standing Member
Buy-Sell-Trade Rating: (2)
Manual Shifting Problems

I have a 2007 ST 5 speed. very hard to get into any gear. It improves as it warms up (driving a couple of miles). It does have Steeda Short Shifter if that matters. It has 92,000k on the clock, as far as I know the fluid has never been changed.


__________________
Shoeman
shoeman is online now  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-26-2019, 02:45 PM   #2
Focus Addict
 
Paul1958's Avatar
 
Join Date: Apr 2014
Fan#: 157234
Location: Hudson, MA
What I Drive: 2002 Focus wagon 2.0L Zetec 5-speed

Posts: 809
Points 4,944, Level 44
Points: 4,944, Level: 44 Points: 4,944, Level: 44 Points: 4,944, Level: 44
Level Up 97% Completed
Level up: 97% Level up: 97% Level up: 97%
Forum Activity 69%
Activity: 69% Activity: 69% Activity: 69%
FF Reputation: 16 Paul1958 Great Standing Member
Buy-Sell-Trade Rating: (0)
With the engine OFF does it go into gears easily?

Paul
__________________
2005 ZX4 SE 2.0L Duratec 5-speed 191K miles
2002 Wagon SE 2.0L Zetec 5-speed 135K miles
Paul1958 is offline  
    Reply With Quote Quick reply to this message
Old 07-30-2019, 09:13 PM   #3
Focus Enthusiast
 
Join Date: Apr 2005
Fan#: 21303
Location: St. Louis, MO
What I Drive: 2007 ST & 97 Cobra

Posts: 70
Points 705, Level 14
Points: 705, Level: 14 Points: 705, Level: 14 Points: 705, Level: 14
Level Up 5% Completed
Level up: 5% Level up: 5% Level up: 5%
Forum Activity 5%
Activity: 5% Activity: 5% Activity: 5%
FF Reputation: 1 shoeman Good Standing Member
Buy-Sell-Trade Rating: (2)
Hadn't driven in a couple of days, wouldn't go into any gear. Lifted up on the clutch pedal and pumped it several times and I then could shift to all gears. I think it might be a clutch issue.
__________________
Shoeman
shoeman is online now  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-31-2019, 08:27 AM   #4
Focus Rookie
 
Join Date: Jul 2019
Fan#: 414605
Location: Grove CIty, PA
What I Drive: 2010 Sangria Red Focus SE

Posts: 8
Points 14, Level 1
Points: 14, Level: 1 Points: 14, Level: 1 Points: 14, Level: 1
Level Up 27% Completed
Level up: 27% Level up: 27% Level up: 27%
Forum Activity 25%
Activity: 25% Activity: 25% Activity: 25%
FF Reputation: 1 Jimbob72jug Good Standing Member
Buy-Sell-Trade Rating: (0)
Mine was doing the same thing now still waiting to get all my clutch parts put into car.
Jimbob72jug is offline  
    Reply With Quote Quick reply to this message
Old 08-10-2019, 08:25 AM   #5
Focus Rookie
 
Join Date: Jul 2019
Fan#: 414605
Location: Grove CIty, PA
What I Drive: 2010 Sangria Red Focus SE

Posts: 8
Points 14, Level 1
Points: 14, Level: 1 Points: 14, Level: 1 Points: 14, Level: 1
Level Up 27% Completed
Level up: 27% Level up: 27% Level up: 27%
Forum Activity 25%
Activity: 25% Activity: 25% Activity: 25%
FF Reputation: 1 Jimbob72jug Good Standing Member
Buy-Sell-Trade Rating: (0)
Turns out mine was the slave cylinder gone bad but the new clutch, slave cylinder, and pressure plate worked out wonderfully the car drives like it was new
Jimbob72jug is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Focus Centennial Edition Sedan
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:59 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum and Volvo XC90 Forum.




 

Search Engine Optimization by vBSEO 3.6.1