Loss of power at higher RPM after Steeda short ram install - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus First Generation > DURATEC Performance (2003-2007)

DURATEC Performance (2003-2007) The place to chat about any Duratec 23, 23E, and 20 engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest

Reply
 
LinkBack Thread Tools Display Modes
Old 07-30-2014, 10:25 AM   #1
Focus Rookie
 
Join Date: Mar 2014
Fan#: 147010
Location: Mission Viejo, CA
What I Drive: 2006 Toreador Red ZX3

Posts: 3
Points 39, Level 1
Points: 39, Level: 1 Points: 39, Level: 1 Points: 39, Level: 1
Level Up 78% Completed
Level up: 78% Level up: 78% Level up: 78%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 Zephyranthes Good Standing Member
Buy-Sell-Trade Rating: (0)
Loss of power at higher RPM after Steeda short ram install

Hey guys,

Installed a Steeda short ram intake on my 06 Duratec last night and since then it has been intermittently losing power at higher RPM in every gear.

I've disconnected the negative batt terminal and let the car idle to allow the ECU to adjust.

The symptoms are strange. I'll be in any gear, and as soon as I hit the higher rev range, the car just bucks like a wild buffalo and I watch the speedo drop. I still hear the engine revving but the car just stops putting down power.

I've noticed if I completely let off of the gas and then depress the pedal again, I get power back for about 5-10 seconds before it bucks again and repeats itself.

Any ideas? I'm going to clean the MAF in like 30. Hopefully it does something.

The car has 70k on it and was running like a dream until last night


Zephyranthes is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-30-2014, 10:48 AM   #2
So mote be it
 
rambleon84's Avatar
 
Join Date: Nov 2007
Fan#: 51521
Location: columbus, OH
What I Drive: 2007 ZX3 2013 ST3

Posts: 8,754
Points 13,055, Level 74
Points: 13,055, Level: 74 Points: 13,055, Level: 74 Points: 13,055, Level: 74
Level Up 52% Completed
Level up: 52% Level up: 52% Level up: 52%
Forum Activity 32%
Activity: 32% Activity: 32% Activity: 32%
FF Reputation: 42 rambleon84 Great Standing Member
Buy-Sell-Trade Rating: (15)
Any check engine lights?

I would verify you reinstalled the maf going in the right direction and that every connection is snug/air tight (not overly tight, especially where the tube connects to the TB.)
rambleon84 is offline  
    Reply With Quote Quick reply to this message
Old 07-30-2014, 11:42 AM   #3
Focus Rookie
 
Join Date: Mar 2014
Fan#: 147010
Location: Mission Viejo, CA
What I Drive: 2006 Toreador Red ZX3

Posts: 3
Points 39, Level 1
Points: 39, Level: 1 Points: 39, Level: 1 Points: 39, Level: 1
Level Up 78% Completed
Level up: 78% Level up: 78% Level up: 78%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 Zephyranthes Good Standing Member
Buy-Sell-Trade Rating: (0)
No CEL up to this point. Just cleaned the MAF and ensured it is installed properly. There's actually only one way it bolts into the intake pipe, so I assume that it is the correct direction.

I'm at work so I can't really drive it yet. :\
Zephyranthes is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-30-2014, 12:14 PM   #4
w/ my magic bag
 
felixthecat's Avatar
 
Join Date: Nov 2010
Fan#: 80663
Location: The Jet city, WA
What I Drive: '05 Silver Sport Technologies

Posts: 29,031
Points 34,752, Level 100
Points: 34,752, Level: 100 Points: 34,752, Level: 100 Points: 34,752, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 100%
Activity: 100% Activity: 100% Activity: 100%
FF Reputation: 87 felixthecat Excellent Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Zephyranthes View Post
No CEL up to this point. Just cleaned the MAF and ensured it is installed properly. There's actually only one way it bolts into the intake pipe, so I assume that it is the correct direction.

I'm at work so I can't really drive it yet. :\
Yea, it only screws in one way= I'd make sure the steedas tube is installed the right direction.
__________________
Introduce Mr. Torsen to the mix
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Bigger brakes then you- D23 crew- D-Tech- Sedan Revolution= #131
R.I.P....Mr Felix, 5-2-02... 5-24-19
felixthecat is offline  
    Reply With Quote Quick reply to this message
Old 07-30-2014, 08:48 PM   #5
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 30,051
Points 100,544, Level 100
Points: 100,544, Level: 100 Points: 100,544, Level: 100 Points: 100,544, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 100%
Activity: 100% Activity: 100% Activity: 100%
FF Reputation: 160 1turbofocus Excellent Standing Member 1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (31)
More then likely your fueling and load is off , very common when installing a new intake

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Phone: 704-249-3745
Site:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Elder 1turbofocus
1turbofocus is offline  
    Reply With Quote Quick reply to this message
Old 07-30-2014, 09:42 PM   #6
Focus Rookie
 
Join Date: Mar 2014
Fan#: 147010
Location: Mission Viejo, CA
What I Drive: 2006 Toreador Red ZX3

Posts: 3
Points 39, Level 1
Points: 39, Level: 1 Points: 39, Level: 1 Points: 39, Level: 1
Level Up 78% Completed
Level up: 78% Level up: 78% Level up: 78%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 Zephyranthes Good Standing Member
Buy-Sell-Trade Rating: (0)
Thanks guys. I just returned from a drive, and cleaning the MAF/TB did wonders. She's happy as a clam!

Appreciate all the responses.

Y'all are awesome.
Zephyranthes is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Focus Centennial Edition Sedan
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:38 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum and Volvo XC90 Forum.




 

Search Engine Optimization by vBSEO 3.6.1